Pro Site CSS & Choosing Plan -ish issues.

To make things simple,
I have two irksome issues.

Just for some added information, I'd like to note -
1. I have "Signup on Checkout" disabled.
2. I have free plan enabled.
3. I am using "New Blog Templates" at signup

Time to get to the missions!
Here are the quests -

1. There seems to be CSS conflict which is messing up how the pricing table appears

2. After signing up, when the user tries to access the backend of their newly created site, they are redirected to the pricing page - which is absolutely fine however, clicking on "Choose Plan" doesn't get them anywhere. Even on the free option.

Hope to resolve this as soon as possible. Please do help out.
Thank you.

  • Luís

    Hi Masato ,

    Hope you're doing well today!

    1) The CSS issue only happens when New Blog Templates is enabled? Can you give us more informations about the corrections you want to do?

    .period-selector-container.input-with-label span, .period-selector-container label{
        display: inline;

    2) In Pro-Sites -> Settings, if you check the field "Show Signup Message", and click in the link displayed in the checkout page, this issue still happens?

    Cheers, Luís

      • Jude

        Hi again Masato

        Sorry about the delay here.

        1) The CSS correction -
        as you can see in the screenshot that "Pro" is not equally leveled with "Free" and "Starter"
        and, on the selector above, "monthly" isn't equally leveled with "quarterly" and "annually".
        The CSS issue doesn't have anything to do with New Blog Template.

        .period-option.period1 {
            margin-top: 5px;

        2) I have enabled the option that you mentioned above and still nothing happens when I click "Choose Plan".

        I see you are using VC on the page, can you turn it off and try again please ?