Pro Site Not Creating Blog Upon Signup

I have a user (the first) who is attempting to create a site/payment through Pro Sites 3.5.0.1 (upgraded from the previous version), and it is not working. The flow of what's happening is:

1. User fills out details for new blog, gets message that site is reserved but not yet activated, and that trial begins once site is activated, and at end of activation they'll be upgraded to their chosen plan, and to fill out the payment details.

2. User fills out credit card (Stripe) information, press subscribe, the page reloads but nothing happens. No site is created, but their payment information is processed by Stripe.

Error log shows:

WordPress database error Unknown column 'subscription_id' in 'field list' for query SELECT customer_id, subscription_id FROM wp_pro_sites_stripe_customers WHERE blog_id = 6 made by require('wp-blog-header.php'), require_once('wp-includes/template-loader.php'), include('/themes/gravial/page.php'), the_content, apply_filters('the_content'), call_user_func_array, ProSites->checkout_output, apply_filters('psts_primary_checkout_table'), call_user_func_array, ProSites_View_Front_Checkout::render_checkout_page, apply_filters('prosites_render_checkout_page'), call_user_func_array, ProSites_View_Front_Gateway::prepend_plan_details, ProSites_View_Front_Gateway::render_notification_information, call_user_func, ProSites_Gateway_Stripe::get_existing_user_information, ProSites_Gateway_Stripe::get_customer_data, m_wpdb->query

End result: User has user account created, but does not receive a blog activation email and blog is not created. They do receive other emails, such as password recovery.

Note: I just turned on debug mode and have the following errors:

Notice: is_page was called incorrectly. Conditional query tags do not work before the query is run. Before then, they always return false. Please see Debugging in WordPress for more information. (This message was added in version 3.1.) in /home/gravial/public_html/wp-includes/functions.php on line 3560 

Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at /home/gravial/public_html/wp-includes/functions.php:3560) in /home/gravial/public_html/wp-content/plugins/pro-sites/pro-sites-files/lib/ProSites/Helper/Session.php on line 29 

Strict Standards: Only variables should be passed by reference in /home/gravial/public_html/wp-content/plugins/wpmu-dev-seo/wds-files/wds-core/admin/wds-core-admin.php on line 245 

Strict Standards: Only variables should be passed by reference in /home/gravial/public_html/wp-content/plugins/wpmu-dev-seo/wds-files/wds-core/admin/wds-core-admin.php on line 245

I have Wordfence running for caching, and that's the only notable plugin I can think of to mention. It is currently turned off and the problem still persists. Further, when debug_mode is turned on in wp-config, I get these errors when trying to delete a user (the user does get deleted):

Notice: is_page was called incorrectly. Conditional query tags do not work before the query is run. Before then, they always return false. Please see Debugging in WordPress for more information. (This message was added in version 3.1.) in /home/gravial/public_html/wp-includes/functions.php on line 3560

Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at /home/gravial/public_html/wp-includes/functions.php:3560) in /home/gravial/public_html/wp-content/plugins/pro-sites/pro-sites-files/lib/ProSites/Helper/Session.php on line 29

Strict Standards: Only variables should be passed by reference in /home/gravial/public_html/wp-content/plugins/wpmu-dev-seo/wds-files/wds-core/admin/wds-core-admin.php on line 245

Strict Standards: Only variables should be passed by reference in /home/gravial/public_html/wp-content/plugins/wpmu-dev-seo/wds-files/wds-core/admin/wds-core-admin.php on line 245

Warning: Cannot modify header information - headers already sent by (output started at /home/gravial/public_html/wp-includes/functions.php:3560) in /home/gravial/public_html/wp-includes/pluggable.php on line 1196

* I have enabled support access.