Pro site not working/not reliable

i want to build subscription website but, pro site not really reliable. for example, when i set payment as manual, it is only activated if i pass the activation link(manually to the user) then the pro site activated. if i manually activate using activation code on dashboard, the client still cannot access the site. {very frustrating this part}

secondly, i tried using paypal express. i tried with my user that has account already, and I can go through the payment process flawlessly for the second site. but, for a new user, after they made payment they dont receive any email and the site not activated. {this part even frustrating}

So, pro site not reliable and frustrating for a premium plugin.

Im thinking to take a look at membership 2 pro. but i need to relearn and resetting everything.

  • Nithin
    • Support Wizard

    Hi khai,

    Hope you are doing good today. :slight_smile:

    for example, when i set payment as manual, it is only activated if i pass the activation link(manually to the user) then the pro site activated. if i manually activate using activation code on dashboard, the client still cannot access the site. {very frustrating this part}

    Sorry to hear about your experience. Once the super admin could confirm the payments are made, the Manual payment can be made work either by activating the link by the super admin which should send an email with the subsite login credientials to the user who has created the site. Or you could send the activation link to the member as you have done as stated.

    It should work fine in both the ways, I tested in my system, and activated the site, and the subsite admin could login to the new subsite without any issue.

    We'll need to test his further to see what exact is causing this issue.

    secondly, i tried using paypal express. i tried with my user that has account already, and I can go through the payment process flawlessly for the second site. but, for a new user, after they made payment they dont receive any email and the site not activated. {this part even frustrating}

    Regarding this, it seems like you are using a Live PayPal Gateway at the moment, so I wasn't able to test this out in our side.

    Could you please double check whether you have added PayPal IPN as instructed in the plugin side?

    Since support access to your site is disabled at the moment, I wasn't able to give closer look at how the plugins are configured.

    Could you please grant support staff access so that we could give a closer look. You can grant access from WPMU DEV > Support > Support Access > Grant Access, or check this manual: https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-5

    Please let us know once you enable access, so that we could get this sorted. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Nithin
    • Support Wizard

    Hi khai,

    Sorry for the delay in getting back to you, it seems like the support access has been disabled at the moment, so wasn't able to give a closer look at the WordPress dashboard side.

    about the email, no the user dont get the activation email

    Since in both the cases the issue was with receiving emails, could you please confirm whether emails works in general in your system?

    Could you please use a plugin like:
    https://wordpress.org/plugins/wp-mail-logging/

    And check whether emails gets sent in general in your system? Either the issue is with emails not getting sent, or the emails are ending up in Spam.

    In both cases, setting up SMTP plugins would help in resolving such issues, you can find this article on how to configure SMTP plugin:
    https://www.wpbeginner.com/wp-tutorials/how-to-use-smtp-server-to-send-wordpress-emails/

    If you still have issues regarding these, and not sure how to test it out, then please share your sites login credentials, so that we could give a closer look.

    You can send credentials by using our secure contact form: https://premium.wpmudev.org/contact/#i-have-a-different-question

    - To Mark to my attention, the subject line should contain only: ATTN: Nithin Ramdas
    -WordPress admin username
    -WordPress admin password
    -login url
    -FTP credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant urls

    Please do follow up in the ticket once you have sent the above credentials. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.