Pro Site & Other Plugins (.htaccess conflicts)

I have ProSites installed and configured. This is my .htaccess code per my Network settings page:

RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]

# uploaded files
RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]
RewriteRule ^wp-signup\.php(.*)$ wp-content/themes/_MYTHEME/wp-signup.php$1

RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^ - [L]
RewriteRule . index.php [L]

I have another plugin that does some backend security and some mod-rewrites for the login/setup/admin URLs. The plugin asks me to replace the existing .htaccess with the following:

# BEGIN Better WP Security
<IfModule mod_rewrite.c>
RewriteEngine On

RewriteRule ^login/?$ /wp-login.php?1uuqb4e5dwdlpwdeh15or [R,L]

RewriteCond %{HTTP_COOKIE} !^.*wordpress_logged_in_.*$
RewriteRule ^dashboard/?$ /wp-login.php?1uuqb4e5dwdlpwdeh15or&redirect_to=/wp-admin/ [R,L]

RewriteRule ^dashboard/?$ /wp-admin/?1uuqb4e5dwdlpwdeh15or [R,L]

RewriteRule ^signup/?$ /wp-login.php?1uuqb4e5dwdlpwdeh15or&action=register [R,L]

RewriteCond %{SCRIPT_FILENAME} !^(.*)admin-ajax\.php
RewriteCond %{HTTP_REFERER} !^(.*)mysite.com/wp-admin
RewriteCond %{HTTP_REFERER} !^(.*)mysite.com/wp-login\.php
RewriteCond %{HTTP_REFERER} !^(.*)mysite.com/login
RewriteCond %{HTTP_REFERER} !^(.*)mysite.com/dashboard
RewriteCond %{HTTP_REFERER} !^(.*)mysite.com/signup
RewriteCond %{QUERY_STRING} !^1uuqb4e5dwdlpwdeh15or
RewriteCond %{QUERY_STRING} !^action=logout
RewriteCond %{QUERY_STRING} !^action=rp
RewriteCond %{QUERY_STRING} !^action=register
RewriteCond %{QUERY_STRING} !^action=postpass
RewriteCond %{HTTP_COOKIE} !^.*wordpress_logged_in_.*$
RewriteRule ^.*wp-admin/?|^.*wp-login\.php /not_found [R,L]

RewriteCond %{QUERY_STRING} ^loggedout=true
RewriteRule ^.*$ /wp-login.php?1uuqb4e5dwdlpwdeh15or [R,L]
</IfModule>
# END Better WP Security

If I leave the #Better WP Security code in there, my /pro-sites/ page becomes a 404 error and users can't upgrade their sites, but /login/ and /dashboard/ work great. I can't seem to get the right combo to get both to work. Can someone help me figure this out?

Thanks!