Pro Sites coupon not applying to PayPal total, not showing up as a use

Hello good WPMUdev-ers-

I'm having an issue with the coupons on Pro Sites. The coupon, when applied, shows the discount on the level panes (screenshot attached), but when one is selected and I go to PayPal (using Express), the discount has not been applied to the total. Furthermore, even if I go through with that sale, the coupon itself has not been logged as having been used. It's still at "0". Recurring payments are turned off on Pro Sites.

We do intend to go to PP Payments Pro at some point, but not yet, and I don't think that's it. The discount never makes the transition to PayPal.

Try it! The coupon is TESTING and the discount is an indefinite 99% off any level. Link. I'll nuke the test accounts later.

Thanks for your consideration of help.

  • Adam Czajczyk
    • Support Gorilla

    Hey @awemaker,

    I hope you're well today and thank you for your question!

    I'm not aware of any know bugs that might be causing this, however I know that the issue did come up a few times before. That said, could you please start with the following steps?

    1. If you're using any caching plugin (such as W3 Total Cache), please empty all caches and disable it.

    2. Turn off all the plugins except Pro Sites, check for the issue, then enable plugins back one-by-one each time checking for the issue again

    3. If it still doesn't help, try to revert to default WP Twenty Fifteen theme for a moment.

    If none of the above works, then please advise:

    - what hosting do you use (a link to the plan would be great)
    - is there any caching enabled on your server?
    - are you aware of any load-balancing turned on on your sever?
    - are you using CloudFlare or similar service to server your site?

    It would be also great if you could grant me an access to your dashboard so I could take a closer look at your setup. To do this, please follow this guide:

    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Cheers,
    Adam

  • awemaker
    • Design Lord, Child of Thor

    Thanks for your speedy reply, Adam!
    1) I deactivated WP-Super Cache. No change.
    2) I deactivated all plugins (even WPMU Dashboard; will re-instate to grant support access) except Pro Sites, both at the network level and at the base-site level (barbertime.com). No change.
    3) The theme IS the default Twenty-Fifteen, so no change there.

    I'm using the HostGator Reseller account, aluminum. HostGator chat support tells me that it is negative on the caching and load-balancing on the server, and I'm not using CloudFlare or similar at this time. (Nor have I used it here yet.)

    Thanks for looking into this.

  • Adam Czajczyk
    • Support Gorilla

    Hey @awemaker,

    Thanks for this information.

    I've checked your site and it seems that it's configured as it should. There's indeed nothing that could cause any trouble. However, it turned out that some other members of our community had also reported similar issues.

    In this case this has been already marked as a bug, so hopefully our developers will find a solution soon and most likely include it in future release.

    Please keep an eye on this thread for further updates and information and try to keep your Pro Sites plugin up-to-date.

    Cheers,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.