Pro Sites email confirmation does not contain key activation

When I tried to submit using manual payment, the email I received from the Pro Sites have no activation key nor the activation link. Here is the email I received when someone upgrade to Pro Status using manual payment submission.

The user "site1" has submitted a manual payment request via the Pro Sites checkout form.
Level: 1 - Basic
Period: Every 12 Months
User Email: site1@balidirectoryportal.com
Activation Key:
Activation Link: http://wp-activate.php?key=
Site Address: http://balidirectoryportal.com
Manage Site: http://gslide.balidirectoryportal.com/wp-admin/
Coupon Used:
Payment Amount: 50
User-Entered Comments:

  • Predrag Dubajic
    • Support

    Hi @Adebagus,

    Hope you're doing well today :slight_smile:

    Can you please give us some more info about this, are you using only Manual payment or you are also using one of the available gateways?

    Would you mind allowing support access so we can have a closer look at your setup?
    To enable support access you can check the screenshot attached below.

    Best regards,
    Predrag

  • Adam Czajczyk
    • Support Gorilla

    Hello Adebagus,

    I hope you're well today!

    I just tested this on my own setup and by default an activation key should be included in this notification e-mail as a "raw" key as well as in activation URL. However, the test was conducted on a "clean"/default install so it's highly possible that it's different on your setup.

    For example, there are some plugins that "overtake" user registration process or change it, there may be some custom code that's affecting registration process etc. That doesn't necessarily mean that lack of activation key is a bug here but in order to investigate it further I'd need to take a closer look at your setup.

    Would you mind granting me a support access via our WPMU DEV Dashboard plugin so I could take a closer look?

    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Best regards,
    Adam

  • Predrag Dubajic
    • Support

    Hi Adebagus,

    Thanks for granting access, I have checked your installation and noticed that you have over 40 plugins active on your site.
    Can you try disabling everything except the Pro Sites plugin switch to default WP theme and see if in that case activation key is included in the email, this will tell us if there's indeed a conflict on your site that's causing this.

    Best regards,
    Predrag

  • Adebagus
    • Flash Drive

    Hi Predrag,
    I already deactivated all plugin except Pro Sites but result is still the same.
    Here is the email

    The user "sample" has submitted a manual payment request via the Pro Sites checkout form.

    Level: 1 - Basic
    Period: Every 1 Months
    User Email: mkresna2@gmail.com
    Activation Key:
    Activation Link: http://wp-activate.php?key=
    Site Address: http://balidirectoryportal.com
    Manage Site: http://sample.balidirectoryportal.com/wp-admin/
    Coupon Used:
    Payment Amount: 6
    User-Entered Comments:
    grant me access trial

  • Predrag Dubajic
    • Support

    Hi Adebagus,

    I managed to dig up the same report as yours and user in that case reported that he managed to get it working after installing WP again.
    However I believe that the issue might just be that the plugin was not installed properly, so instead of reinstalling entire WP can you just try reinstalling Pro Sites plugin, but do try via FTP this time?

    Best regards,
    Predrag

  • Predrag Dubajic
    • Support

    Hi Adebagus,

    I believe I have found the cause of this.

    On your site you don't have active option for users to register sites, only logged in members can create a site, is that correct?

    With this kind of setup I was also able to replicate this issue.
    The activation key is only included in the email when you enable Both sites and user accounts can be registered. option in network settings.

    I have notified plugin developer about this issue, thank you for bringing it up to our attention!

    If deactivate and reinstall the plugin, can I get the setup as before I reinstall? It's quite a lot of job to setup again

    Just for future reference, most of plugins (including Pro Sites) save the settings in database so after you reinstall it the settings will still be there.
    There's also an option to access your files via FTP and overwrite the current folder with the new one, this way you'll be sure your settings stay intact no matter which theme/plugin you're reinstalling.

    Best regards,
    Predrag

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.