[Pro Sites] eNom option not visiable in ProSite and Domain Mapping plugin

I have installed and network activate the Pro-site and Domain Mapping plugin on venture8.wpengine.com. I configured all settings of plugis given in documentation section but not see the eNom option where user purchase domain. I also not see the Domain Mapping menu under tools of users subsite.

  • Adam Czajczyk

    Hello dan

    I hope you're well today and thank you for your question!

    I configured all settings of plugis given in documentation section but not see the eNom option where user purchase domain.

    The eNom options should be configured first on "Network Admin -> Settings -> Domain Mapping -> Reseller options" page. Once it's setup there, there won't be any "front-end" domain purchase option and the Pro Site checkout will be the same as without it. Instead, after creating a sub-site, a sub-site admin would have an option to register own domain available under "Tools -> Domain Mapping" in that sub-site back-end.

    I also not see the Domain Mapping menu under tools of users subsite.

    When used with Pro Sites, Domain Mapping feature can be made available to all or only selected Pro Sites levels. For example, if you have levels "Basic" and "VIP" and also a free level enabled and it's set to be available only for "VIP" level - only those who signed up for "VIP" Pro Sites level will see that option.

    To check this, please go to "Network Admin -> Settings -> Domain Mapping" page -> "Mapping options" tab and scroll it all the way down. There should be a "Select Pro Sites Levels" option at the bottom, listing all your existing Pro Sites levels.

    If they are all un-checked, Domain Mapping should be available for all sites but if some are checked, it will be available only for sites of these specific levels (that also includes eNom option for purchasing domain).

    If that doesn't help, I'd need to take a closer look at your setup so in that case, please enable support access to your site by going to "Network Admin -> WPMU DEV -> Support" page and clicking on "Grant support access" button there. Let me know when it's enabled.

    Best regards,
    Adam

  • Predrag Dubajic

    Hi Dan,

    Please don't leave your login details in forum tickets as they are publicly accessible and well indexed by search engines.

    About your issue, in your network admin under Settings > Domain Mapping you have selected options only for Pro Sites to have option to map domains, however the subsite you mentioned above doesn't have any pro site level assigned.

    If you go to Sites > All Sites and next to your subsite click on Manage you will see Pro Sites settings and from there you can assign a pro site level to that subsite.
    After you've assigned a level the domain mapping settings will appear on that subsite under Tools > Domain Mappin.

    Best regards,
    Predrag

  • dan

    Hello Predrag,

    Thanks for your support.
    I have another question. I have seen the domain mapping menu in the case of stripe but not in paypal.
    When I checkout with PayPal then I am not able to see the prosite level(Silver, Gold and Platinum) in "Network Admin=> Sites". Here I am found "Manage" instead of correct selected level.
    Please let me know if I miss any PayPal gateway settings.

    Thanks

  • Adam Czajczyk

    Hello dan

    Do I correctly understand that if you checkout with Stripe the Pro Site level is assigned to the newly created site but if you checkout with PayPal, it is not?

    If so, then this might mean indeed that there's something wrong with configuration. Usually there are two issues that might be causing this so please go to "Pro Sites -> Payment Gateways -> PayPal Express" page in your site's Network Admin and check:

    1. if PayPal Mode setting and PayPal API Credentials are consistent; What I mean is that if it's set to Test Mode (sandbox) it has to use credentials for sandbox; take a look here: https://developer.paypal.com/docs/classic/api/apiCredentials/

    Accordingly, if PayPal Mode is set to Live, credentials must be for your real PayPal account.

    2. Make sure that you have IPN notifications turned on on your account and IPN URL is set to the one given on Pro Sites -> Payment Gateways -> PayPal Express page in your site's "Network Admin".

    Please double-check that and let me know if that solved the problem. If not, I'll need to take a closer look at your setup so in that case please also let me know and enable support access to the site. To enable support access, go to the "WPMU DEV -> Support" page in your site's Network Admin and click on "Grant Support Access" button there.

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.