Pro-sites free signup redirect loop after registering

When a free account is set up, they can not immediately get to the new account, but they do receive an email with login info. If they follow the login into to the admin panel, they get looped back to the pricing page and it takes 30+ mins before they can login.

The question then is how do we solve this and if we can't solve it, can we redirect them to another page in the meantime.

site: +++hub.com

  • James Morris
    • WordPress Enthusiast

    Hello Audra @Zindo

    I hope you are well today.

    Checking your configuration, it looks as though all new sites are registered with the HTTP:// protocol but something in your WP Engine configuration is forcing HTTPS:// protocol on all subsites. This is what is causing the redirect loop. When I registered wpmudevjames.*****hub.com, if I accessed it from https://wpmudevjames.*****hub.com/ (HTTPS) it was available immediately. But, if I tried to access http://wpmudevjames.*****hub.com/ (HTTP) it would take about 30 minutes for the WP Engine system to catch up and start recognizing the URL.

    Would you please double check your settings in WP Engine and ensure that ALL URL references for your multisite are pointing to the HTTPS protocol. With WP Engine, you have to have a special option enabled in order to run this type of setup. You may need to contact their support to enable it.

    Please see the following links for more detail.
    https://wpengine.com/support/multisite-how-to-add-new-sites/
    https://wpengine.com/support/do-i-have-to-manually-add-each-multisite-sub-site-to-my-account/

    As far as redirecting users on signup, I'm afraid that's not possible without modifying the core plugin files, at this time.

    I hope this clarifies a bit. Let us know if you have any further questions. We'll be happy to help! :slight_smile:

    Best regards,

    James Morris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.