Pro sites interrupting with all my WordPress work flow and giving away multiple errors continuously

Pro sites is interrupting with all my WordPress work flow and giving away multiple errors continuously. Also as a result sometimes pages are failing to load and sometimes some plugin or other function fails/breaks down.
Below are the errors I saw in my "/publim_html/error_log" file:

[02-Feb-2017 06:27:00 UTC] PHP Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at /home/ashleati/public_html/wp-content/mu-plugins/ms-functions.php:17) in /home/ashleati/public_html/wp-content/plugins/pro-sites/pro-sites-files/lib/ProSites/Helper/Session.php on line 29
[02-Feb-2017 06:27:00 UTC] PHP Warning: Cannot modify header information - headers already sent by (output started at /home/ashleati/public_html/wp-content/mu-plugins/ms-functions.php:17) in /home/ashleati/public_html/wp-login.php on line 394
[02-Feb-2017 06:27:00 UTC] PHP Warning: Cannot modify header information - headers already sent by (output started at /home/ashleati/public_html/wp-content/mu-plugins/ms-functions.php:17) in /home/ashleati/public_html/wp-login.php on line 407

[02-Feb-2017 06:47:51 UTC] WordPress database error Table 'ashleati_wp701.wphv_pro_sites_stripe_customers' doesn't exist for query SELECT customer_id, subscription_id FROM wphv_pro_sites_stripe_customers WHERE blog_id = 4 made by wpmu_activate_signup, do_action('wpmu_activate_blog'), WP_Hook->do_action, WP_Hook->apply_filters, call_user_func_array, ProSites->process_manual_signup, ProSites->extend, ProSites_Gateway_Stripe::attempt_manual_reactivation, ProSites_Gateway_Stripe::get_customer_data
[02-Feb-2017 06:47:51 UTC] WordPress database error Table 'ashleati_wp701.wphv_pro_sites_stripe_customers' doesn't exist for query SELECT customer_id FROM wphv_pro_sites_stripe_customers WHERE blog_id = 4 made by wpmu_activate_signup, do_action('wpmu_activate_blog'), WP_Hook->do_action, WP_Hook->apply_filters, call_user_func_array, ProSites->process_manual_signup, ProSites->extend, ProSites_Gateway_Stripe::attempt_manual_reactivation, ProSites_Gateway_Stripe::get_customer_data
[02-Feb-2017 06:48:57 UTC] WordPress database error Table 'ashleati_wp701.wphv_pro_sites_stripe_customers' doesn't exist for query SELECT customer_id, subscription_id FROM wphv_pro_sites_stripe_customers WHERE blog_id = 5 made by wpmu_activate_signup, do_action('wpmu_activate_blog'), WP_Hook->do_action, WP_Hook->apply_filters, call_user_func_array, ProSites->process_manual_signup, ProSites->extend, ProSites_Gateway_Stripe::attempt_manual_reactivation, ProSites_Gateway_Stripe::get_customer_data
[02-Feb-2017 06:48:57 UTC] WordPress database error Table 'ashleati_wp701.wphv_pro_sites_stripe_customers' doesn't exist for query SELECT customer_id FROM wphv_pro_sites_stripe_customers WHERE blog_id = 5 made by wpmu_activate_signup, do_action('wpmu_activate_blog'), WP_Hook->do_action, WP_Hook->apply_filters, call_user_func_array, ProSites->process_manual_signup, ProSites->extend, ProSites_Gateway_Stripe::attempt_manual_reactivation, ProSites_Gateway_Stripe::get_customer_data

Please study this log carefully and suggest me solutions to prevent all these errors from occuring. Early replies appreciated as it's an urgent assignment that can't be completed withut WPMU DEV (it's plugins and support of course :wink: ).

  • Rupok

    Hi Arpita,

    So sorry for the inconvenience you are having and thanks for sharing the error log data. I've analyzed the data. Let me describe one by one.

    [02-Feb-2017 06:27:00 UTC] PHP Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at /home/ashleati/public_html/wp-content/mu-plugins/ms-functions.php:17) in /home/ashleati/public_html/wp-content/plugins/pro-sites/pro-sites-files/lib/ProSites/Helper/Session.php on line 29

    It seems like you have a MU Plugin and the file name is "ms-functions.php". This must use plugin is conflicting with Pro Sites. Can you please download that file on your computer and remove from the server? That will fix this issue.

    As I don't know what code is there in that must use plugin, I'm not sure why the conflict is occurring. From the errors, it seems like there is an empty space on line 17 of that file. Can you please check? If you find any empty space on that line, please remove that, save that file and check if this error is gone?

    [02-Feb-2017 06:27:00 UTC] PHP Warning: Cannot modify header information - headers already sent by (output started at /home/ashleati/public_html/wp-content/mu-plugins/ms-functions.php:17) in /home/ashleati/public_html/wp-login.php on line 394
    [02-Feb-2017 06:27:00 UTC] PHP Warning: Cannot modify header information - headers already sent by (output started at /home/ashleati/public_html/wp-content/mu-plugins/ms-functions.php:17) in /home/ashleati/public_html/wp-login.php on line 407

    Can you please try the suggestion I just provided above? If empty space is the issue, then removing that empty space should remove these two warnings too.

    The rest of the errors indicates that a table named "wphv_pro_sites_stripe_customers" is missing in your database. Can you please confirm if your database is totally writable? If yes, can you please try reinstalling the Pro Sites plugin and also reconfiguring the Stripe Payment Gateway in Pro Sites?

    I believe, these will help. Please let us know how these go. I'm looking forward to hearing from you and resolving this issue as soon as possible.

    Have a nice day. Cheers!
    Rupok

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.