Pro Sites: Links to payment page not working

The links to the Pro payment page aren’t working because they contain the pageID.

The link will look like this:

http://domain/?page_id=45089?bid=2995

Which will load to the correct payment page:

http://domain/prosite/?page_id=45089?bid=2995

I don’t know where the page_id querystring parameter in comes from. The link will work if I delete the ?page_id=45089 from the url or change the ? before bid to &.

Is this a bug? Or did I mis configured something?

Thanks in advance,

Pieter

  • Kimberly
    • Champion of Loops

    Pieter,

    Hi there!

    Could you give some additional info about how you are coming to this error? As in, are you clicking and getting routed to the wrong place and that is what you see as the url?

    You should make sure your permalinks are also set to something other than default. This can cause issues with the craziest of things sometimes. :slight_smile:

    Best,

    Kimberly

  • aecnu
    • WP Unicorn

    Greetings pbrink,

    Thank you for being a WPMU Dev member!

    I went through a thorough test on our production server and the link for payment is in the following correct format: http://mydomain.com/pro-site/?bid=10

    It appears something is amiss there with your configuration though I cannot reproduce the error.

    I would suggest resetting your permalinks to anything but default.

    Otherwise as I had mentioned earlier and unfortunately I cannot reproduce the error and think there is some kind of misconfiguration somewhere if the permalinks reset does not fix it.

    Cheers, Joe :slight_smile:

    If this thread is not resolved because the suggested action did not work or you have any more questions related to this thread, please feel free to post them below including any new symptoms or errors and tick the ‘Mark as Not Resolved (re-open)’ box below the post area (or else we’ll miss it!)

  • pbrink
    • Site Builder, Child of Zeus

    Kimberly, thanks for your reply,

    The payment page is on:

    http://domain/prosite/?bid=2995 on this page the user can choose his/her level and press the paypal button. Alle links (generated by prosites) to this paymentpage are generated based on the pageid so the URL includes the pageid querystring parameter. Like this:

    http://domain/?page_id=45089?bid=2995

    The main site then redirects you to the current page (including the querystring parameters), URL that the user then visits is http://domain/prosite/?page_id=45089?bid=2995.

    This page will show with your site where you can choose which site you want to upgrade, but all the links are including the ?page_id=45089?bid=2995. The links should only have the bid (blogid) or have a & between the paramenters, like ?page_id=45089&bid=2995

    The permalinksettings of my main blog is:

    /%postname%/

    The permalinksettings of the userblogs.

    /%postname%/%year%/%monthnum%/%day%/

    I don´t see any problems in those settings.

    The fix shouldn’t be so hard. Some where in the plugin the link to the payment page is generated. Check that link if it already contains a ? is so generate the URL with a &bid= instead of ?bid=. I haven’t had time to check the code, but it would be real nice if the developer could answer this question.

    @joe, It’s real easy to check this on a clean install and I now that is the right way of doing this. But I don’t think that your answer was in anyway helping me resolving my issue. You haven’t tried with different permalink settings. My guess is if you set the permalinksettings to standard (?p=123), you will run into the same problems. My feeling to-words your answer is that your mission is to close as many support topics as possible.

  • 3SixtyEvolve
    • New Recruit

    Hi pbrink

    Greetings from the WPMU DEV Support Team and thank you for your further feedback regarding the Pro Sites Plugin.

    I’ve flagged the Developer for support and will also follow up with the other Support Team for possible feedback/ and or solutions.

    I’m a newbie at WPMU DEV and your problem is slightly above my expertize, so I can’t really be of more service to you. However, I will personally follow this thread to make sure that someone else assist you in solving this matter.

    And in the meantime, if you require any further assistance with any other topic/ plugin, please don’t hesitate to be in touch.

    Have a good day!

    Gina :: Multiplicity

    Trying out as WPMU DEV Support Staff – Let me know how I go

  • Aaron
    • CTO

    The only reason that ?page_id=45089 would be added to a permalink is if pretty permalinks were disabled when you installed pro sites. Not sure how that was achieved.

    To reset the checkout url, you need to trash & delete the current assigned checkout page, then go and save the pro sites settings page. That should detect the page missing, create a new page, and reset the url.

  • dwconcepts
    • New Recruit

    I had the same issue. The Pro Site’s links with “bid” in the query string were just displaying a blank page. I also noticed my “Edit Checkout Page” link was not working under the Pro Sites > Settings menu. Once I re-saved the “Pro Sites” page that was already created, I was back in business. This has been causing me great pain for the last 3 days.

    Thanks for the fix!

  • Aaron
    • CTO

    Your rewrite is breaking things. Default rules for multisite are:

    # BEGIN WordPress
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index.php$ - [L]

    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule . index.php [L]
    # END WordPress

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.