Pro Sites not accepting payment

Hi,

We are having a wierd issue with pro-sites...It is hit or miss...when someone is signing up for a website and it gets to the credit card form with stripe...some users it's working perfectly fine, and others it just redirects to the pro-sites page with no error...I have tested many times over and i get to the place to either pay for a new site, or pay for a renewal, i select my plan. Then i put in the credit card info...It refreshes the page, and the only text that appears on the top of the site is showing the date it expires...

Your current plan
Plan expires on: April 1, 2016

Which is the same day as today. I check the pro-sites log for that site ID and there is nothing there. I also check stripe and there are no failed charges or a customer being created..As far as I can tell there are no logs being thrown or errors in the console as well. Please advise. I have opened up support help as well.

  • Adam Czajczyk

    Hello forthgear,

    I hope you're well today and thank you for your question!

    I've accessed your site and reviewed its settings. It seems at first look that there's nothing wrong there so we'll need to dig a little bit deeper.

    Could you please recall and let me know if this started to happen only recently or did it happen for some time already? Did it started with some recent updates and/or were there any changes made to the site closely before the issue occurred for the first time?

    Looking forward for you replay!

    Best regards,
    Adam

  • Adam Czajczyk

    Hello forthgear!

    Thanks for an answer. I took a look at your Pro Sites checkout page (the "Sign up for the blog" page on the site assigned to this thread) and I can see that there's only yearly payment period enabled. I just came across an error related to PayPal settings which occurs in case of such a setting. It may be possible this affects Stripe too so could you please add another payment period to your Pro Sites level (e.g. 6 months) and check if this still happens?

    If not, could you please also confirm if the same happens if you disable all the plugins but Pro Sites and switch to Twenty Fifteen theme?

    Let me know please!
    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.