Pro Sites not working

I was on a live chat with Huberson Dorvilus but got cut off. I have unlocked support access to my network.

When you got to the pro sites url: https://yobd.digital/portal/yobd-takeaways/ and you try to register with test stripe details (https://stripe.com/docs/testing) nothing happens. It registers the user but not the site. And there are no success or error messages. I have WP_DEBUG and WP_DEBUG_LOG set to true and WP_DEBUG_DISPLAY set to false but there is nothing there.

Stripe records the API calls but no transactions are going through.

  • Joseph
    • WPMU DEV Initiate

    just check the debug.log file this morning and found these two errors from yesterday:

    [18-Jun-2018 21:16:27 UTC] Error in /path/to/file/wp-content/plugins/pro-sites/pro-sites-files/gateways/gateway-stripe.php at line 421Received unknown parameter: name
    [18-Jun-2018 21:16:27 UTC] PHP Warning: A non-numeric value encountered in /path/to/file/wp-content/plugins/pro-sites/pro-sites-files/gateways/gateway-stripe.php on line 410

  • James Morris
    • WordPress Enthusiast

    Hello Joseph

    In order to help you better with your issue, would you please grant me access to your site and server so I can perform some advanced debugging?

    NOTE: Please make a full backup of your site before sending the following information.

    Please visit the Contact page and complete the form with the following information:

    https://premium.wpmudev.org/contact/#i-have-a-different-question

    Option: I have a different Question

    Subject: “Attn: James Morris”

    In the Message box, please provide the following:

    – link back to this thread for reference

    – any other relevant urls

    – Admin login:

    Admin username

    Admin password

    Login url

    – Hosting Control Panel Login

    Admin username

    Admin password

    Login url

    ~OR~

    – FTP credentials

    host

    username

    password

    (and port if required)

    Best regards,

    James Morris

  • James Morris
    • WordPress Enthusiast

    Hello Joseph

    I’ve been looking into this issue further, but I’m afraid I’ve exhausted what I can do on this. I’ve flagged this ticket for our SLS Team (code experts) so that they can dig into this issue deeper for you. An update will be posted here as soon as more information is available. Thank you for your patience while we sort through this issue.

    Best regards,

    James Morris

  • Joseph
    • WPMU DEV Initiate

    Thank James.

    I appreciate everything you are doing, but just to make you aware our sales reps were planning on starting tomorrow. Anything we can get our developer to do on our end to help? For the time being we will use Paypal.

    Many thanks

  • Panos
    • SLS

    Hi Joseph ,

    Thanks for reporting this.

    I tried accessing your files via ftp, but I couldn’t find the wp installation. I have attached a file here which you can try replacing. File to replace is :

    wp-content/plugins/pro-sites/pro-sites-files/gateways/gateway-stripe.php

    with the one attached.

    I would suggest to keep a backup of original file by simply renaming it to gateway-stripe.php.txt.

    Once you replace this file, please go to WP Admin > Pro Sites > Levels and click on the “Save Levels”.

    Then you should be able to use Stripe. Please let us know how this goes on your side :slight_smile:

    Kind regards!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.