Pro-Sites on Existing Multi-Site Install Suspends all Sites - This site is temporarily disabled

I have an existing Multi-Site installation with 30 existing clients and websites. It's integrated with WHMCS and I use the WHMCS Provisioning Module. I'd like to have three different Multi-site options but as soon as I enable the Pro-Sites plugin, all my current clients see this on their sites:

This site is temporarily disabled until payment is received. Please check back later.

I can't have their websites showing that while I'm setting up Pro-Sites. Is there some sort of work around?

  • Lee Perry

    I'm setting up something similar.

    My existing clients I've manually upgraded to pro site bypassing the temporarily disabled page. That caught me out at first too.

    Themes - Network disabling themes to add to the theme package manager does not seem to remove them from existing installs, and downgrading an account does not appear to remove them either.

    Plugins - Not sure, but suspect they would work in the same way as themes.

    I would:
    1. Temporarily disable pay to blog - thereby removing the warning
    2. Create a pro site level that contains all themes and plugins using the relevant modules
    3. Manually upgrade all existing sites to that level
    4. Turn pay to blog back on
    5. Crack on with setting up pro sites with custom theme and plugin packages
    6. Move existing clients around between levels as appropriate

  • Sajid

    Hi Justin,

    Hope you are doing good today :slight_smile:

    My existing clients I've manually upgraded to pro site bypassing the temporarily disabled page. That caught me out at first too.

    Yes, that's a good move. You can manually set pro level for your existing clients. That option is only for users who signed up as a free user but you don't want them to publish content without receiving the payments.

    Themes - Network disabling themes to add to the theme package manager does not seem to remove them from existing installs, and downgrading an account does not appear to remove them either.

    Premium Themes - Seems to working fine for me. I created a test site with free level and restricted a theme for basic level only. When I logged in I could not activate that theme, instead of activate button there were name of level and link to upgrade page as seen in attached screenshot.

    Then I upgraded that site to Basic level, got access to that theme, this time instead of Level name and link to upgrade page I could see Activate text with activate link as seen in second screenshot.

    Same results while upgrading and downgrading that site in different levels. So it seems to be working fine as it suppose to work.

    It will not remove it from themes panel completely will just restrict access and redirect to checkout page to upgrade.

    Hope that help! Feel free to post a reply if you need further assistance :slight_smile:

    Cheers, Sajid

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.