Pro sites paid only membership

I have a couple of issues with Pro Sites that I can't seem to get around.

1. I want it to be paid only with no option for free signup. The way it seems to work is that the only way to have paid sites is to have everyone sign up for a free site first and then upgrade. My preference is to have people pay either prior to creating their login and blog or as part of the signup process.

2. On the signup page (this is a subdomain wpmu site) it is displaying http on the blog url after the subdomain name. So, to the customer it looks like the URL of their site will be like:

http://mysite.http://domain.com

It doesn't affect the blogs - they are created fine - it's just a display issue but it is definitely something that needs to be fixed. I can't see anywhere in any of the Wordpress or plugin settings where it allows me to change that.

Gary

  • Jack Kitterhing

    Hi there Gary @teckyhead

    1: You can activate the "pay to blog" module in pro sites and delete the free level, then create the levels with prices. With "pay to blog" activated, upon login the first time they will be redirected to pay, make sure that you tick the box that reads "completely disable the site both front-end and admin till paid" If you need further details on this, let me know, I'd be happy to provide screenshots.

    2: That is a bit strange, could you supply a URL to your website please? I'll see if I can create the issue, so you've got a multisite install of wordpress on a subdomain, running a sub domain setup?

    Thanks!

    Kind Regards
    Jack (Coding-Monkey).

  • teckyhead

    Hi Jack,

    Thanks for your reply. Yep - I've already enabled pro sites and only have a single, paid level. I guess I'll edit the registration page - I just want people to know before they sign up that the site isn't splog heaven and that signing up for free will get them absolutely nowhere. I have anti-splog installed but the hard core sploggers still try :slight_smile:. I've only had the site set up a week or two and have had a bunch of sploggers creating free accounts.

    Regarding the signup page - the site isn't fully set up yet but if you go here:

    http://geneblogs.com/register/

    ...and scroll down and click the 'yes I'd like to create a new site' checkbox you will see what I mean. My biggest problem is that I can't see where it's coming from. There is nowhere in the settings that the domain appears with http:// at the start of it and in the wp-config.php the DOMAIN_CURRENT_SITE is set correctly with just the domain in there.

    Gary

  • teckyhead

    Hi Tom,

    No - the only plugins I've installed so far are Pro Sites and Anti Splog. I did find where the registration page was pulling the domain from though. It uses the siteurl field in the wp_options table. When I removed the http:// from that field it also removed it from the domain on the registration page.

    It doesn't really make sense though as the site url field really should have http:// at the start of it.

    Gary

  • Jack Kitterhing

    Hi there Gary (@teckyhead)

    I hope that you are well today :slight_smile:

    I was just going through some old threads and noticed this one hadn't been resolved yet.

    I apologize about the extreme delay here. With regards to the issue at hand, when Multisite is installed and it says above removing the www. part from the domain name (required if your using sub domains). This will strip the http:// from the start of the domain, the only way I've got it to show is if I force SSL on and then I have the HTTPS show, but of course this only works if you have a valid wildcard SSL certificate.

    Again, I'm very sorry about the delay here.

    Kind Regards
    Jack.