Pro Sites payment gateway – settings do not save

Hello

I have set up a WP Multisite network and I have installed the Pro Sites plugin. I want to use the Stripe payment gateway as well as offering manual payments.

On the Gateway Settings > Stripe page I tick the Enable Gateway checkbox and click Save Changes. The page reloads and the admin message says Gateway Saved but the Enable Gateway checkbox is no longer ticked.

If I go to the Gateway Settings > Manual Payments page and tick the Enable Gateway checkbox then Save Changes, the checkbox remains ticked. However, if I then visit the Currency Settings page (I want to use £ instead of $) the currency menu is unavailable and it says Enable gateways.

If I go back to the Gateway Settings > Stripe page and try again to enable gateway again, this disables the Manual Payment setting.

I have the Pro Site plugin set up and working on my local computer and the Gateway Settings > Stripe page shows a comprehensive range of settings such as Stripe Mode, Stripe API Credentials, etc.

The Gateway Settings > Stripe page on the live site only shows the Enable Gateway checkbox.

Previously I had a few problems with server permissions in the web directory. Could this problem be related to file permissions?

Thanks for your help.

    Adam Czajczyk

    Hello dunmc,

    I hope you're well today and thank you for your question!

    I've visited your site's dashboard using support access that you granted and I can confirm the issue. There's however no console errors and not other signs that could indicate what's wrong here.

    You mentioned some issues related to permissions, could you please elaborate a bit on this?

    It would be also great if you could give following steps a try:

    1. Network de-activate Pro Sites plugin
    2. access your server via FTP
    3. go to /wp-content/plugins folder
    4. delete entire "pro-sites" folder
    5. download Pro Sites plugin from this page:
    https://premium.wpmudev.org/project/pro-sites/

    6. extract archive and upload "pro-sites" folder from it to your server's /wp-content/plugins folder
    7. access your database via phpMyAdmin and select all tables ("Check all")
    8. use "With selected" drop-down option "Optimize table" and execute it
    9. network-enable Pro Sites again.

    Let me know please if it helped!

    Best regards,
    Adam

    duncmc

    Adam

    Thanks for your reply. I removed the Pro Sites plugin and reinstalled a freshly downloaded copy by FTP – non change.

    Then I checked the server logs. I should have done this in the first place as it highlighted the actual cause of the problem – Stripe needs the CURL PHP extension. I have installed the extension on the server and it all seems to be working now.

    I have marked the ticket as resolved.

    Regards,

    Duncan