Pro sites pricing error

When displaying prices below 1000, the pricing table does a weird trick. See video.

What could this be? We would like to price our product at 999, but are unable to

    Rupok

    Hi Casper,

    So sorry to hear the inconvenience you are having. And thanks for granting Support Access. I logged in to regenerate the issue on your site, but I could not regenerate that on your site because the updated price in Dashboard is not being reflected in front-end. I've created a video screencast showing this: http://take.ms/WQ4jS

    I could not regenerate any of these on my test site. So I think, this is your site specific issue.

    Just to make sure no other plugin is causing this, can you please do a plugin conflict test? To know more about plugin conflict test, you can check this guide: http://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/ . Can you also try disabling taxamo for your site and check what happens?

    Please let us know the results of your tests. I'm looking forward to hearing from you and resolving this issue as soon as possible.

    Have a nice day. Cheers!
    Rupok

    Casper

    Hi Rupok,

    I have disabled CDN for our network, price change should update instantly now. If not, try a hard reload with cache flush.

    Disabling taxamo makes the issue go away, so far so good. With taxamo enabled, visiting the page from a non-eu country like your country also solves the issue, so we now know that the VAT/TAX calculation does something weird. To replicate the issue as I see it, try visiting the page via a VPN set to Denmark, and you should see it too.

    Also; the taxamo dashboard is not registering sales. I had a meeting with taxamo support staff who helped me getting set up on their end, but to no avail.

    All in all, I'm convinced the issue lies with taxamo or the taxamo integration in pro sites. Taxamo were unable to assist me further, since they are not able to review the integration itself, so I am hoping WPMU can do some digging for me.

    A nice day to you too!
    Casper

    Rupok

    Hi Casper,

    Thanks for sending these details. We tried to regenerate the issue on our test site with taxamo enable and configured. Only the digits after the dots go away after enabling taxamo but nothing happens like your site. So I think, this is your site specific issue.

    Now as we could not regenerate this on our test site, I'm not sure if there is anything wrong in our integration scripting. Can you please do the plugin conflict test I requested above? Or did you do already? Can you please confirm the issue is same on your site even when all other plugins are disabled?

    I'm looking forward to hearing from you and resolving this issue as soon as possible.

    Have a nice day. Cheers!
    Rupok

    Casper

    Hi Rupok,

    With all plugins (except Pro Sites and WPMU DEV Dashboard) disabled, the issue persists. I did some more research.

    The number 124875 is the sum of 99900*1,25, which is the danish VAT rate. So a decimal is missing (should be 999.00 and 1,248.75).

    I played around with the "Show decimals" under currency settings, and took a screenshot of both settings. Screenshots are attached.

    When decimals should be hidden, it is actually only the dot that is hidden, the result being 124875 - the decimals, 75, are still there. Should have been 1,248.

    The one time setup fee is acting even more weird; when decimals are set to show, the one time fee says 1.25 which means VAT (1.25) must have been added, but the dot is placed 3 spaces to soon (should have been 1,250).

    When decimals should be hidden, the one time fee says 1,000, which means VAT has NOT been calculated for it. (should have been 1,250).

    What do you make of this?

    NB; All transactions go through perfectly, with the correct VAT calculated; the issues are only cosmetic.

    Casper

    I

    Nithin

    Hi Casper,

    Hope you are doing good today.

    Thank you for sharing your observation, the issue maybe related to this, but to be sure, I would like to replicate the exact in my system, but I wasn't able to. Is there any specific steps that should be done to replicate this? Do we need to input any vat rates? I suppose the vat rates should be calculated automatically with Denmark IP, if that's the case, I wasn't able to replicate the exact issue. Could you please advise what I'm missing here?

    Also, please enable support access, so that we could give a closer look, and if possible ping the developers for his view on this issue. You can grant access from WPMU DEV > Support > Support Access > Grant Access, or check this manual: http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Please let us know once you enable access, so that we could get this sorted. Have a nice day.

    Kind Regards,
    Nithin

    Casper

    Hi Nithin,

    I believe Taxamo is the culprit here. It will not trigger a VAT calculation until it is sure of your location. I am able to trigger a VAT calculation this way:

    1. Set a VPN server to a EU country, for example Denmark.
    2. Refresh your browser. Taxamo should have detected your IP change (screenshot)
    3. Taxamo might still show you pricing for your native country. In the bottom right taxamo menu, change your location to the same location your VPN is set to (screenshot)
    4. You should see a VAT calculation now.

    Also, the price is now 1.000 recurring and 1.000 up front. This looks great with out calculation, but shows as 1.25 and 1.25 after calculation. I think this issue might be as simple as bad logic regarding the use of "." and "," when taxamo gets involved.

    As we will be moving forward with a workaround, I've set up a staging environment for you at: https://ptwebnew.staging.wpengine.com/pro-site/

    Support is enabled for the staging environment.

    Thank you,
    Casper

    Nithin

    Hi Casper,

    Hope you are doing good today.

    I believe Taxamo is the culprit here. It will not trigger a VAT calculation until it is sure of your location. I am able to trigger a VAT calculation this way:

    I was able to notice the issue in your system, and I was able to replicate the same in my system too. As you have observed, this might be related to Taxamo, could you please get in touch with Taxamo regarding this, so that we could have a better idea about how this works when it comes to Denmark region, and check whether they have any solution regarding this.

    I'm also bringing this in attention to the developer, to check whether he's aware of any such instances. It seems like you have already figured out a workaround, it might help other members, if you could share your workaround.

    Please let us know how that goes, have a nice day.

    Kind Regards,
    Nithin

    Casper

    Hi Nithin,

    Thank you for your reply.

    Regarding Taxamo being the culprit, I was referring to you and Rupok not being able to replicate.

    I'm currently convinced that Pro Sites is playing a part in this issue, in how it enterprets the data being sendt from Taxamo. I would be happy to investigate with one of your developers via a hangout, as I have made myself very familiar with the system and the issue by now.

    If you would like me to reach out to Taxamo I would be happy to, but I am unsure what I should tell them, as the plugin is not theirs. As I wrote earlier, I already had a call with a Taxamo representative who was unable to give me further support as I'm using a 3rd party system (Pro Sites). If you could instruct me, please.

    The workaround I mentioned is not really a workaround. We are able to launch our platform with tolerable issues, when the price is DKK 1000 ($140) or above, and when "show decimals" is set to Yes. The tolerable issues are 1. Prices are currently not showing VAT in the checkout flow, which means a discrepancy between the checkout and the invoice, and 2. At some point we would like to price our product lower.

    Let me know what is next!

    Regards,
    Casper

    Rupok

    Hi Casper,

    So sorry for the inconvenience you are still having. I've pinged our developer regarding this again. I believe, he will come up with his valuable feedback on this very soon. We will update you as soon as we get anything from him.

    Please keep in mind, our developers work round the clock and they have to deal with lots of critical issues and other things. So it may take a little while for them to check this and provide a feedback.

    I'll appreciate your patience.

    Have a nice day. Cheers!
    Rupok

    Nithin

    Hello Casper,

    We checked this with the developer, however on further testing it seems that we aren't able to replicate this issue anymore in the latest version of Pro Site plugin, ie v 3.5.5.

    I could see you are still using the previous version of Pro Sites plugin ie v 3.5.4. Please update the plugin to the latest version, and let us know whether it works fine, or not. And we'll make sure to get back to you asap.

    Kind Regards,
    Nithin

    Casper

    Hi Nithin,

    I updated to v 3.5.5 on my staging site, but the bug is still there. See vid:

    https://www.dropbox.com/s/9et6vba4z7q3fyo/pricing%20error%20june.mov?dl=0

    I documented how to trigger the issue earlier in this thread:

    Hi Nithin,

    I believe Taxamo is the culprit here. It will not trigger a VAT calculation until it is sure of your location. I am able to trigger a VAT calculation this way:

    1. Set a VPN server to a EU country, for example Denmark.
    2. Refresh your browser. Taxamo should have detected your IP change (screenshot)
    3. Taxamo might still show you pricing for your native country. In the bottom right taxamo menu, change your location to the same location your VPN is set to (screenshot)
    4. You should see a VAT calculation now.

    Also, the price is now 1.000 recurring and 1.000 up front. This looks great with out calculation, but shows as 1.25 and 1.25 after calculation. I think this issue might be as simple as bad logic regarding the use of "." and "," when taxamo gets involved.

    As we will be moving forward with a workaround, I've set up a staging environment for you at: https://ptwebnew.staging.wpengine.com/pro-site/

    Support is enabled for the staging environment.

    The staging environment is currently password protected. How can I pass this on to you?

    Casper