[Pro Sites] Pro Sites Registration Email

When a new user creates a Pro Site they provide a User Name and an email address to create a user account but no password. I had expected Pro Sites to generate an email to them but it does not. It seems to log them in to the main site without a password. When their Prosite welcome email arrives they are asked to login but don't have a password, forcing (if they are bright) a password recovery. I tried to resolve this using the "Set Password on Multisite Blog Creation" plugin, which does drop a password on the form, but the passwords I enter do not seem to work. Should Pro Site be triggering a registration email? It says it will but mine does not. I have deactivated all plugins to test but still no registration mail. And is there any setting not to have the user automatically logged in on creating their Prosite?

  • James Morris

    Hello Conor

    I hope you are well today.

    I've just tested this on a fresh install of WordPress 4.9.6 with the latest version of Pro Sites (3.5.9) and I'm afraid I cannot replicate the symptoms you are seeing.

    When I create an account, the welcome email I get has the username, password and login URL included in the email body. See screenshot...

    https://i.imgur.com/ZESPf0C.png

    If you are not seeing this combination of information in the welcome emails, then something, somewhere is striping the information out. Have you checked to see if you have any mu-plugins installed that affect emails?

    Best regards,

    James Morris

  • Conor

    I have tried this with all plugins off on the network and the main site whilst the running the 2015 theme and it still doesn't send the registration email to the user. I thought it might be the mail function so activated Postman but the logs don't record an attempt to send a registration mail.

    As a workaround I will probably make them register before accessing the Pro Sites page but it would be good to work out why this is happening as I like the easy flow or registering as part of the pro sites signup.

  • James Morris

    Hello Conor

    Would you please install the Email Log plugin and run through a couple registrations. If the emails are being generated by WordPress, it will show in that plugin. If there are emails generated, but not sent, then there is likely a communications/permissions issue between your site and your email. You may need to check your server logs through your hosting to determine if there is an issue there. If no email log is generated upon registration, then there is a problem in the software that we will need to investigate further.

    Best regards,

    James Morris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.