[Pro Sites] Stripe Error

Hi Support Team,

Currently we are using Paypal as the live payment gateway and added Stripe as the alternative payment gateway but set as test mode for our Prosite. The stripe account is newly created which uses the latest stripe API version. We also uploaded the gateway-stripe.php fix as mentioned in this instruction https://premium.wpmudev.org/forums/topic/pro-site-test-payment-not-processing#post-1308480 and re-saved the Levels which successfully created the plans in Stripe. However, after submitting the credit card form, prosite only creates the user account, but no website was created. It just shows the same pro-site page with the pricing plan table but the title has been changed to “Change your plan”, which indicates that I am logged-in. Also, there’s an error in the payment gateway – https://www.screencast.com/t/aWyX80wj0. What could be the problem and how to fix this?

Regards

  • Adam Czajczyk
    • Support Gorilla

    Hello Dave

    I hope you’re well today and thank you for your question!

    I checked your site and I can see the issue there.

    I tried to replicate this on my end and I run multiple tests on my test setup with Stripe in test mode with current api with patch applied but I couldn’t get the same result. In all cases both user account and the site were registered for me.

    This leads me to thinking that this is most likely specific to the setup. Could you please start with checking these two things:

    1. Since you are using Stripe test mode – make sure that your Stripe account is actually set to a stripe mode, not live one

    2. Double-check webhooks settings as explained in this post:

    https://premium.wpmudev.org/forums/topic/pro-site-test-payment-not-processing#post-1304974

    3. Finally, open a new browser tab in incognito mode and visit the webhook URL (the one copied from Pro Sites -> Payment Gateways -> Stripe” page. See what are you getting in response – is it any page on your site or is it a blank page with just “0” number on it?

    If the first two points are confirmed and the 3rd one returns blank page with “0” number, clear all browser caches, log out and test Pro Sites checkout again.

    If it still doesn’t work or the 3rd step is not confirmed, please enable support access to the site so I could take a closer look. To do this, please go to the “Network Admin -> WPMU DEV -> Support” page in your site’s back-end, click on “Grant support access” button and let me know here.

    Best regards,

    Adam

  • Dave
    • Flash Drive

    Hi Adam,

    I followed the 3 steps:

    1. I used the stripe test api keys in prosite stripe settings.

    2. I added the webhook in both test and live mode on stripe.

    3. The hook returns 0.

    Still it is not creating the site. Finally I have enabled support access. Let me know if there’s anything you need.

    Regards

  • Predrag Dubajic
    • Support

    Hi Dave,

    Can you please try applying the below patch and let us know if it works fine for you.

    You will first need to download the attached file and unzip it.

    Now access your WP files via FTP or cPanel and navigate to wp-content/plugins/pro-sites/pro-sites-files/gateways/ folder where you need to replace existing file with the one I’ve attached.

    You will now need to clear all the caching you have and then go to Pro Sites > Levels panel.

    From there just save the settings so that levels get created on your Stripe account and that should do the trick.

    Let us know how it goes.

    Best regards,

    Predrag

  • Dave
    • Flash Drive

    Hi Predrag,

    I uploaded and replaced gateway-stripe.ph, deleted all test data in stripe, and resaved the Levels in prosite. The products were recreated in Stripe. When I tested it, the site is still not created. I get the same error result: “The Stripe customer could not be retrieved. Please try again.”.

    Regards

  • Predrag Dubajic
    • Support

    Hi Dave,

    Hmm, we tested this patch on a couple of installations and it worked there.

    Could you provide us with FTP or cPanel login details so we can check why the fix didn’t work for you?

    Note: Don’t leave your login details in this ticket.

    Instead, you can send us your details using our contact form https://premium.wpmudev.org/contact/#i-have-a-different-question and the template below:

    Subject: “Attn: Predrag Dubajic

    – Site login URL

    – WordPress admin username

    – WordPress admin password

    – FTP credentials (host/username/password)

    – cPanel credentials (host/username/password)

    – Folder path to the site in question

    – Link back to this thread for reference

    – Any other relevant urls/info

    Best regards,

    Predrag

  • Predrag Dubajic
    • Support

    Hi Dave,

    Thanks for sending those in, we were doing some extensive testing on your site and actually got it working at one point when USD was selected as currency, but after switching back to AUD and USD again it didn’t continue working.

    There’s something strange going on there and I’ll need to involve our dev guys to investigate it further and see what’s going on there, hopefully they will be able to shed some light on this.

    Best regards,

    Predrag

  • Panos
    • SLS

    Hey Dave ,

    The issue is that somehow the new user registered has bbp_participant capability for main blog.

    There is a core WordPress function, get_blogs_of_user(), used by ProSites to get user’s existing blog ids. That function uses the capabilities as you can see from the linked page, so it returns the main blog as any user’s blog id.

    The customer_id connected to that blog_id would be wrong so it causes this issue. I have added a new mu-plugin mu-plugins/ps-filter-get_blogs_of_user.php that should be fixing this.

    Could you please do a few tests on your side too to confirm?

    Thanks!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.