Pro Sites Registration Conflicting with Membership2 Pro Registration

Hi,

I just upgraded from Membership Pro to Membership2 Pro. It is activated site-by-site. This way each site can have it's own members and permissions. I also have Pro Sites network activated so visitors can subscribe and create new sites.

When a visitor to a sub-site tries to Register as a Member to the sub-site, they receive first the Membership levels available page, then going forward they receive a Registration page with both the Membership2 and Pro Sites registration information.

Also, I'm using the Terms of Service Plugin. The TOS info also appears twice on the Registration page.

There is also an Anti-Splog plugin conflict as this error message appears at the bottom of the page:
"Fatal error: Call to a member function get_error_message() on a non-object in /home/theweeb/public_html/wp-content/plugins/anti-splog/anti-splog.php on line 1582"

Any suggestions?
Thanks,
Chuck S.

  • Vinod Dalvi
    • WP Unicorn

    Hi Chuck S.,

    Sorry to hear of the problem you are having.

    When a visitor to a sub-site tries to Register as a Member to the sub-site, they receive first the Membership levels available page, then going forward they receive a Registration page with both the Membership2 and Pro Sites registration information.

    I couldn't reproduce the issue on my test site using latest versions of Membership2 and Pro Sites plugins and activating the Membership2 plugin side by side.

    Could you please share any sub site URL from your multisite network so that i can test it on your site?

    Also would you mind if I logged in to your site and did some troubleshooting? This might help get to the bottom of this faster. If this is ok, just grant me temporary admin access to your site by clicking "Grant Access" button in the WPMU DEV Dashboard Settings as described on the following page and reply on this thread after granting it?

    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Also, I'm using the Terms of Service Plugin. The TOS info also appears twice on the Registration page.

    It seems the plugin conflict issue as reported in the following thread.

    https://premium.wpmudev.org/forums/topic/terms-of-service-showing-up-twice?replies=4#post-897829

    Currently to resolve this issue try using the attached small plugin.

    There is also an Anti-Splog plugin conflict as this error message appears at the bottom of the page:
    "Fatal error: Call to a member function get_error_message() on a non-object in /home/theweeb/public_html/wp-content/plugins/anti-splog/anti-splog.php on line 1582"

    Could you please share the page URL where the error is displaying?

    I don't find it on your site and also couldn't reproduce it on my test site using latest version of Anti-Splog plugin.

    Kind Regards,
    Vinod Dalvi

  • ChuckS
    • The Crimson Coder

    Thank you so much for the quick reply and the plugin. The sub-site is strattonfamily.org. If you would, try registering as a Member on the site and you will see what I have found. It's trying to register the visitor on the network instead of the sub-site. I've tried before to allow admin access through the WPMU DEV dashboard and my server won't allow access, sorry.

    Thanks for the plugin. Works great, now only one TOS.
    Chuck S.

  • ChuckS
    • The Crimson Coder

    Hi,

    I was hoping that the two new updates, Membership 1.0.0.7 and Pro Sites 3.5.0.3, would solve the registration page problems. But, so sad, they didn't. Fortunately, the TOS only shows once now. Thank you!

    Any idea on an update to resolve the other issues?
    Thanks,
    Chuck S.

  • Ash
    • WordPress Hacker

    Hello @ChuckS

    As the bug is related to two plugins, so it's needing some time. I can't give you any ETA unfortunately, but I can ensure you that both developers are working on a fix and I hope very soon the fix will be released.

    We appreciate your patience on this.

    Cheers
    Ash

  • Vinod Dalvi
    • WP Unicorn

    Hi Chuck,

    To resolve the Anti-Splog plugin conflict error Would you mind if I access your site using FTP and did some testing? This might help get to the bottom of this faster. If this is ok, just send log in info through our secured contact form: https://premium.wpmudev.org/contact/
    - Choose "I have a different question"
    - Include my name in the subject "Vinod Dalvi"
    - Include the URL of this post in your message so that I may track this issue better
    - Include login information (Wordpress admin info username + password )
    - Include FTP Details

    I tried to register on your site http://thepromall.com/premium-2/ and found the pro sites level there on selecting it the form is being displayed to create user account and register site by using any premade blog template so what's the issue with it?

    Please advise.

    Regards,
    Vinod Dalvi

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.