Pro Sites Stripe Gateway Error: Invalid timestamp

I'm getting an error with the Stripe gateway. It seems to have begun with a recent Pro Sites update because I've never seen it before. This is the error that shows on the checkout page:
Invalid timestamp: must be an integer Unix timestamp in the future.

I temporarily fixed it by re-saving the Pro Sites settings and Levels, but after one successful transaction it has appeared again. I'm using the latest version of the Stripe API.

Any ideas on fixing this? I'm unable to signup any new customers.

Thanks!

  • Gabe
    • The Bug Hunter

    Here are a couple updates:

    - Strangely, this error will always appear on the first try when a new customer signs up, but will not occur if the page is refreshed and tried a second time or if settings are updated. This leads to mistakenly believing that the error has be fixed.

    - I'm not sure which update broke the plugin, but I reverted to Pro Sites version 3.4.3 and it is working again.

  • Jack Kitterhing
    • Code Norris

    Hi there @Gabe,

    Hope you're well today and thanks for your question.

    So just to clarify, to replicate, install the latest version.

    And do a test signup, and it'll fail, re-save levels with the old version and it'll work again correct?

    Was you testing in sandbox mode or live mode?

    Thanks.

    Kind Regards
    Jack.

  • Gabe
    • The Bug Hunter

    Hi @Jack Kitterhing

    Yep, latest version and I was using live mode with the Stripe gateway with no free trial.

    Yes, I was able to make it work multiple times after refreshing the checkout page (just hitting 'Enter' in the URL bar).

    I wals also able to make it work after savings the Pro Sites settings and Levels, but I only tried this once.

    The error typically occurs when new signups are trying to pay for the first time. I had to create new accounts to replicate the error.

  • Jack Kitterhing
    • Code Norris

    Hi there @Gabe,

    Hope you're well today and sorry about the delay here.

    I've been doing some testing on this on my site and haven't been able to replicate this yet on mine.

    I'm including @Jonathan here for his valuable input on this, thanks for your patience here :slight_smile:

    Kind Regards
    Jack.

  • Jonathan
    • The Bug Hunter

    Hi @Gabe,

    I think I figured out what is going on - you must not have anything set for the "trial days" setting. Try the attached gateway-stripe.php file and let me know if fixes things for you. You'll want to upload it to pro-sites/pro-sites-files/gateways/gateway-stripe.php - make sure you override the existing file that's already there.

    Let me know if that works. :slight_smile:

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.