Pro Sites - There are pending changes to your account.

made some updates like I updated to the latest WordPress and I also updated a couple plugins and getting odd behavior with Pro Sites.
We have paying customers who are now getting messages like their account is inactive, and they can't edit pages.

https://cdn.livechat-static.com/api/file/v2/lc/att-old/8801096/8f0da96e0ca5e032dfdef69e87da98f6/Screen%20Shot%202018-08-02%20at%207.10.41%20PM.png

It is the Beaver builder that is not working but we can edit page with the default builder. Please help.

  • Adam Czajczyk

    Hello Luke Frederick,

    I hope you're well today and thank you for your question!

    I checked the site and I can see the issue there, while the sites seem to be currently set as "active Pro Sites" - they got currently pro sites level assigned. Even if they didn't, you are not using any of the two plugin managers available in Pro Sites so the Beaver Builder should be available regardless of that, as long as the site is not blocked - and they are not.

    Furthermore, the message is an "admin notice" and it's added to the dashboard in other places too but I'm a bit confused about why it's actually breaking Beaver Builder. The Beaver Builder editor there is loaded in an iframe element and the message is injected outside of that iframe. So, in theory, it shouldn't do anything except for just "being there".

    There's no relevant errors in the browser console that could suggest that e.g. some JS scripts are failing due to that message too.

    I must say I'm a bit stuck here so I'm calling out our developers for help with this. I have forwarded the issue to them and am waiting for a feedback so please keep an eye on this ticket (and make sure that the support access is kept active) and we will update you here as soon as we got to know more about the case.

    Kind regards,
    Adam

  • Konstantinos Xenos

    Hi Luke Frederick !

    Could you please open up a Super Admin account for me? I've been trying to replicate the issue on my dev environments with both single payments/subscriptions but unfortunately I wasn't able and beaver builder plays without issues on my end so I'll need to take a closer look.

    Please take a full backup for safe keeping although I will inform you first before proceeding with any changes whatsoever since it's a production site.

    You can send me the information needed privately through our contact form: https://premium.wpmudev.org/contact/#i-have-a-different-question by following this example:

    Subject: "Attn: Konstantinos Xenos"
    
    - Admin login ( if Multisite please provide Super Admin details ):
    Admin Username:
    Admin Password:
    Login URL: 
    
    - Link back to this thread for reference
    - Any other relevant URLs -or- information regarding the issue that was not included in this thread

    Regards,
    Konstantinos

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.