Pro Sites trouble… no redirect to checkout?

When I log on as a new user, and it brings that user to the upgrade to a pro site page, i select a payment plan (monthly, it turns red) and then click the paypal checkout button, it starts to load and then does nothing? it just reloads the same page the user was just on regarding the payment options.

Any idea why this might be?

I just disabled all plugins except the pro sites plugin and it still is responding the same.

A login you can use to see this is here:

user: roofoo

password: roofoo

the error is found here:

Any help is appreciated!

  • Stryker
    • Flash Drive

    Hey Timothy!

    Yes this is fresh install, and the info in the backend for paypal is correct. I had the same info for the marketpress copy pasted to it (the marketpress cart functions great!). Ive tried several of the simple troubleshooting fixes, but yo no avail. What were you saying about the tables?


  • Stryker
    • Flash Drive
    * The base configurations of the WordPress.
    * This file has the following configurations: MySQL settings, Table Prefix,
    * Secret Keys, WordPress Language, and ABSPATH. You can find more information
    * by visiting {@link Editing
    * wp-config.php} Codex page. You can get the MySQL settings from your web host.
    * This file is used by the wp-config.php creation script during the
    * installation. You don't have to use the web site, you can just copy this file
    * to "wp-config.php" and fill in the values.
    * @package WordPress

    // ** MySQL settings - You can get this info from your web host ** //
    /** The name of the database for WordPress */
    define('DB_NAME', 'xxx_xxxx');

    /** MySQL database username */
    define('DB_USER', 'db135177');

    /** MySQL database password */
    define('DB_PASSWORD', 'xxxxxx');

    /** MySQL hostname */
    define('DB_HOST', 'xxxxxxx');

    /** Database Charset to use in creating database tables. */
    define('DB_CHARSET', 'utf8');

    /** The Database Collate type. Don't change this if in doubt. */
    define('DB_COLLATE', '');

    * Authentication Unique Keys and Salts.
    * Change these to different unique phrases!
    * You can generate these using the {@link secret-key service}
    * You can change these at any point in time to invalidate all existing cookies. This will force all users to have to log in again.
    * @since 2.6.0
    define('AUTH_KEY', 'pCr9{U]4@m-j0)LV*6:KVZp^v!soVwj-dl&{



    * WordPress Database Table prefix.


    * You can have multiple installations in one database if you give each a unique

    * prefix. Only numbers, letters, and underscores please!


    $table_prefix = ‘wp_’;


    * WordPress Localized Language, defaults to English.


    * Change this to localize WordPress. A corresponding MO file for the chosen

    * language must be installed to wp-content/languages. For example, install

    * to wp-content/languages and set WPLANG to ‘de_DE’ to enable German

    * language support.


    define(‘WPLANG’, ”:wink:;


    * For developers: WordPress debugging mode.


    * Change this to true to enable the display of notices during development.

    * It is strongly recommended that plugin and theme developers use WP_DEBUG

    * in their development environments.


    define(‘WP_DEBUG’, false);

    define(‘WP_ALLOW_MULTISITE’, true);

    define( ‘MULTISITE’, true );

    define( ‘SUBDOMAIN_INSTALL’, false );

    $base = ‘/’;

    define( ‘DOMAIN_CURRENT_SITE’, ‘’ );

    define( ‘PATH_CURRENT_SITE’, ‘/’ );

    define( ‘SITE_ID_CURRENT_SITE’, 1 );

    define( ‘BLOG_ID_CURRENT_SITE’, 1 );

    /* That’s all, stop editing! Happy blogging. */

    /** Absolute path to the WordPress directory. */

    if ( !defined(‘ABSPATH’:wink: )

    define(‘ABSPATH’, dirname(__FILE__) . ‘/’:wink:;

    /** Sets up WordPress vars and included files. */

    require_once(ABSPATH . ‘wp-settings.php’:wink:;


    Thats what my wp-config file looks like, can you tell me where to input the debug code you suggested?


  • marikamitsos
    • The Crimson Coder

    Going to roofoo site, I notice that there are issues with loading the home page as well. It just won’t load.

    I understand you use a pagelines(?) theme as well as cufons and cubepoints. Meaning you have few javascripts loading.

    I know you have tried disabling extra plugins but had you switched to twentyeleven at the same time?

    Of course Aaron is “the man” with the answers but I thought of giving my 2c as well.

    By the way. If you look close to your wp-config.php you will see that you already have

    define(‘WP_DEBUG’, false);

    Change false to true and under that line add the other two lines Aaron suggested earlier.

    Hope that helps,


  • aecnu
    • WP Unicorn

    Greetings Stryker,

    Just checking if this issue was eventually resolved in another thread? Or by yourself separately to us? Or by us over email with you? Or using our live support?

    If so, no need to reply, that’s great news.

    If not, or you have any more questions related to this thread, please feel free to post them below including any new symptoms or errors and tick the ‘Mark as Not Resolved (re-open)’ box below the post area (or else we’ll miss it!)

    Otherwise, happy days, glad you got it sorted :slight_smile:

    Thank you for being a WPMU Dev member!

    Cheers, Joe :slight_smile:

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.