Pro Sites upgrades not working

Hi,
I'm setting up Pro Sites, have read the available docs, and have questions:

- upgrading using manual payments, no upgrade happens and the message is:
"Finalizing your site...
Thank you for submitting your request for manual payment. We will review your information and email you once your site has been activated or extended."

-upgrading using Stripe (test mode), no upgrade happens and the message is:
"Plan updated...
Your plan was successfully modified from Storefront (quarterly) to Website (quarterly). You will receive a receipt email shortly to confirm this action."

The subsites used to test are '/support' and /'website.' Access is enabled in the MUDEV dashboard plugin.

Other questions:
- there are 3 levels, Basic (no blogging, 3 page limit), Website (full blogging, 10 page limit), Storefront (both unlimited). Pro Sites settings seem correct, but none of this works! Throttling settings do work, but that's not what I need. Premium themes/plugins work.
- Media quota. Is this the total # of images allowed in the Media Gallery?
- Can a different user role be assigned per Pro sites level?
- every site I make now has the message:
"There are pending changes to your account. This message will disappear once these pending changes are completed." What does this mean?
- can that alarmist cancel message and 'gimme a site' (?) be edited in the plugin files, and if so where?
- I'd like the free trial to be Storefront (highest) level. How does it work if they choose a Blog Template with 8 pages, then take a Basic level when the trial is up? And if downgrading to Basic, do pages disappear or become blocked?
- no examples (Blogjob, etc) you posted take new users or look that active. What thriving sites use Pro Sites besides Edu-blogs?
- is there a manuals section for Pro Sites 3.5+ docs yet?

There's lots to like about this plugin! If I can just get it working. Thanks for your help.

Tom

  • Rupok

    Hi Tom, hope you had a wonderful day.

    For manual, when you receive payment details in email, you’ve to manually upgrade it. For stripe, upgrade happens when webhook is received. You can check the webhook status in Stripe logs.

    Pro Sites settings seem correct, but none of this works!

    I could tell you better about the issue if I could see it live, check your current configuration and make some tests on your site. I tried to login with Support Access but it's showing me the following error though I could login once today:
    Sorry, this is an invalid access token. You must ask the user to grant access.
    Can you please revoke and grant us permission again so we can check in details?

    - Is this the total # of images allowed in the Media Gallery?

    This is the number of images you can upload in the Media Gallery from your account.

    - Can a different user role be assigned per Pro sites level?

    I'm afraid, this is not possible out of the box.

    - every site I make now has the message

    Are you using Manual Payment or Stripe? I've described the situation above.

    - can that alarmist cancel message and 'gimme a site' (?) be edited in the plugin files, and if so where?

    I'm sorry but I'm not sure where I can see that message. Can you please give us a screenshot? That will help us understand the issue better and we can guide you better about how you can change that.

    - I'd like the free trial to be Storefront (highest) level. How does it work if they choose a Blog Template with 8 pages, then take a Basic level when the trial is up?

    Then he will be restricted to 3 page again, and can't update last 5 pages without upgrading his level.

    What thriving sites use Pro Sites besides Edu-blogs?

    You can post this query in our Members' Forum. I believe users will come up with their awesome sites.

    - is there a manuals section for Pro Sites 3.5+ docs yet?

    I'm afraid, I'm not clear about your query. Can you please explain a little more so we can understand better and give you better suggestion?

    Please let us know if I missed anything, I'll be glad to assist further.

    I'm looking forward to hear from you and resolve this issue as soon as possible.

    Have a nice day. Cheers!
    Rupok

  • William Palmer

    Hi Rupok,

    Thanks for the response. I did delete the first Support access and started a new one. Hope this one works.

    When starting an account, most settings work. But upgrading/downgrading doesn't work at all. You get a text message that the change was successful. But the account page still shows the old level, and dashboard options are unaffected. Stripe shows each test transaction as going through, so that isn't the problem...

  • Kasia Swiderska

    Hello William,

    When starting an account, most settings work. But upgrading/downgrading doesn't work at all. You get a text message that the change was successful. But the account page still shows the old level, and dashboard options are unaffected.

    Could you check of webhook is set properly in your Stripe account? I tried to replicate this issue on my site but I could not.

    Actually, the page quota and media quota settings for new accounts don't work either. Getting a bit discouraged...

    This one I was able to replicate on my test site. So this is bug and I'm letting developer know about that. As soon as there will be a fix I will update thread with information.

    kind regards,
    Kasia

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.