Pro Sites/Domain Mapping.

I need help making pro sites to work I have disabled it because I was receiving errors and WPDEV API errors as well, its been disabled for about a month because I had bigger issues to take care of which you guys helped me out with a great deal with your other plugins. last 2 that are important to me is Pro Sites/Domain Mapping, and Defender in which I opened up a support request for Defender keeping it separate as you requested. - I have also contacted Hostgator dedicated linux support staff to help me out with server configurations as needed since it is up to me to install, enable anything on my servers for your plugins to work correctly.

Thank You and God Bless - I have activated the 5 day admin support.

  • James

    Hi Vaughn thanks for the reply,

    It turned out to not be any of th WPDEV plugins nor anything else except for two areas.

    1. a gd-config.php file that godaddy had in my core files when i was on shared servers and this file was still connected to their servers api's etc.

    2. the core wordpress and core wordpress database was corrupt.

    I repaired the database then optimized it fixed 98% of problems then did a fresh install of wordpress.

    along with getting help from hostgator to look at the wp-config.php and the gd-config.php files and detach godaddy from my core files as just simply deleting the gd-config.php file just made everything stop working. hg severed me from gd file and we re repaired and optimized the database along with reinstalling wordpress and now i feel better as wordpress is now what I known it to be as for years prior i ran wordpress on a dedicated server without optimization caching cdn etc. and autopost over 10k queries a week and still had good speeds and performance on my dedicated server so to have less than par and no plugins working while I have a cdn etc. made me scratch my head.

    I will say this I am trying to find out how or the best way to revert back from a multi site install to a single install of wordpress. my main site is the only one on this install no other sub sites. is there more steps other than changing the wpconfig file to false.

    after this I will be setting up a fresh install on another domain for a multi site. I decided to keep my main site separate.

    Thanks for your help and God Bless

  • Vaughan

    Hi,

    You should be fine just removing the multisite code from wp-config.php being as you don't have any subsites. Then just regenerate permalinks to be sure :slight_smile:

    You'll also need to edit the htaccess to and add back the original wp htaccess code for a single site install.

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    Hope this helps

  • James

    Thanks I figured everything out, had help reading parts of the gd.php then removed it, followed by repairing the database then optimized the database did a fresh install to repair the core then updated wpmu fixed 99% of the problem the last 1% i created a editor account for each auto blog feed and afterwards everything runs smoothly no db crashes. However now that everything is fixed.

    The auto blog wont auto run not even when i switch the feeds back to super admin im having to manually force process the feeds via each link.

    So im wondering if the repair and reinstall messed up anything or if the software stopped. The last thought is its almost the end of the month to renew wp dev.

    My laptop crashed so im limited on doing stuff with codes but as far as dashboards and server side settings i can flip as needed.

    I notice this past week of no auto run auto blog has cost me the average 740 a week adsense clicks.

    If wpdev is reading this ill have next month payment by the 1st.

  • Vaughan

    Hi James,

    It should be using wp cron to schedule the autoblog feeds, the cron is dependant on front-end visitors, so if your site doesn't have much traffic yet, the cron won't fire.

    You can try using a real cronjob instead.

    This article should explain how to disable WP_CRON & setup a real cron in your cpanel.

    http://support.hostgator.com/articles/specialized-help/technical/wordpress/how-to-replace-wordpress-cron-with-a-real-cron-job

    Hopefully that should fix this issue.

  • James

    Thx we did that at the beginning two months ago everything runs on server cron.

    Today i network deactivated autoblog then reactivated it and went in and reactivated the add ons i was using. And immediately the feeds started working again today.

    Then a few hours later as soon as i re installed defender and finally got that to work without a hitch hardening my server auto blog stopped i thought these plugins supposed to work together but im finding out more and more that most wpdev plugins are either to resource extensive or they gum up the works and have been spending $1000's plus hiring developers to write patches and fixes for these plugins at some point this membership is going to be obsolete with the rate im going with fixing this stuff.

    It came to mind that maybe for the hobbyist with a few dozen to a few hundred sites and not an extremely high organic traffic rate these plugins may suffice but for the bigger sites like mine wpdev edu blog etc etc i think they are using slightly different then what they have here in the plugins and here we have the stripped white label versions which i understand that.

    Thx for your help vaughn, we are working on a patch for auto blog while i uninstall defender and put it in the box with the other poorly wriiten plugins such as crawl seo.

    God bless, James

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.