Problem after moving multisite to sub directory.

I’ve moved all the core file into a new dir for security reasons. The site is running well but the URL is wrong when going to the ‘Network admin’ area of the multisite. Once you’re logged in click on the Network Admin tab in the top left corner – you’ll get a 404 because the ‘wp’ dir is missing from the URL. Once it is added manually it works.

  • Predrag Dubajic
    • Support

    Hey Anthony,

    Hope you’re doing well :slight_smile:

    Can you try modifying your .htaccess file and change these two lines:

    RewriteRule ^(wp-(content|admin|includes).*) $1 [L]
    RewriteRule ^(.*.php)$ $1 [L]

    To this:

    RewriteRule ^(wp-(content|admin|includes).*) wp/$1 [L]
    RewriteRule ^(.*.php)$ wp/$1 [L]

    Let us know if that did the trick for you :slight_smile:

    Best regards,

    Predrag

  • Anthony
    • New Recruit

    Hi Predrag, Thanks – that changed fixed the problem.

    But I have another issue that I think maybe related.

    When logged into the admin panel and I switch to the Dashboard of a subsite I get redirected to /wp/not-found I believe this is caused by the ”hide backend’ feature in ithemes security plugin.

    If I change the URL manually to /wp/wplogin i can log into that dashboard of the subsite (after enter the username and password again)

    Should I open a new ticket for this?

    Thanks

  • Anthony
    • New Recruit

    Hi Predrag, I’ve submitted a bug report with ithemes. I’ve also noticed few other user having the same issue. In the meantime I’ve switched off the ‘hide backend’ feature on ithemes but this has uncovered another small issue.

    When switching to a dashboard of a subsite, you need to enter the login details again. Do i need to enable ‘cross domain auto login’ – I can’t find the setting.

    thanks

  • Predrag Dubajic
    • Support

    Hi Anthony,

    When you login to your network you are logged-in to all your subsites by default in WP, so there shouldn’t be need to enter the username and password again, these redirects that you are having are probably affecting this behaviour as well, so I would suggest checking it again once redirects are sorted out and see if it works after that.

    Best regards,

    Predrag

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.