Problem communicating with WP_CRON: SSL peer certificate or SSH remote key was not OK

This just appeared in the Autoblog area. Can't understand what has caused this or how to fix it.

  • Adam Czajczyk

    Hello Thomas,

    I hope you're well today and thank you for you question!

    The feed that it relates to is available over HTTPS (SSL) connection, is that right? This error may mean one of two things:

    1) there's a "broken" (most likely expired or not valid for given domain) SSL certificate on the "feed end"; these can be easily tested:

    open the feed URL in your browser and see if there's any SSL related warning an/or the browser's "Lock" icon is "crossed" or not green.

    2) There may be a need to update CURL SSL certificates on your server; this would require you to get in touch with your host provider.

    However, even if any of these issues happens first thing I'd try would be to check if the feed is available over a regular HTTP (non-SSL secured) connection as well. If it is then I'd simply replace feed URL in Autoblog settings with "http://" version instead of "https://".

    Best regards,
    Adam

  • Adam Czajczyk

    Hello Thomas!

    So you're fetching feeds from the sub-sites of your own Multisite, is it correct? I wasn't aware of that as well as of a Domain Mapping and forced SSL implemented :slight_smile:

    I understand though that you managed to solve the issue and it's working fine now. Please mark this thread as resolved if you can confirm that. If you have any further questions though, let me know please and I'll be happy to assist you.

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.