Problem creating new blogs after installing Domain Mapping

I successfully installed the Domain Mapping plugin (v2.1.1 on WPMU 2.9.2) and all has been well.

However, since installing, whenever I create a new blog (subdomain) it appears in the blogs list in the WP Admin area, and an entry is created in the wp_blog table. I did notice that no other tables matching the new blog ID exist - not sure if those only get created once the new blog is accessed via the backend, or if they should be created when the blog is created.

Nevertheless, any attempt to visit the new subdomain - either frontend or backend - results in a "server not found" error.

Wildcard DNS is in place and hasn't changed on our server.

  • airfoil
    • Site Builder, Child of Zeus

    Just deleted all blogs (except for the two I need) and created a new blog.

    Tables are there this time for the new blog id, but still - when trying to access either the backend or front end, I get a server not found error.

    Looked at every error log I could find in my system, and there is nothing being reported.

  • airfoil
    • Site Builder, Child of Zeus

    One other note...

    I just tried to access my mapped domain by visiting the subdomain site.

    (mymapped.com => mymapped.mydomain.com)

    When hit mymapped.com all is well - both frontend and backend.

    When I hit mymapped.mydomain.com, I get the server not found error.

    FWIW, I have "domain entered by user" set in Option > Domain Mapping Configuration > Administration Mapping

    Could this be a .htaccess issue? If so, what should I be looking for?

    Again, wildcards are set up in my DNS settings, and worked fine since I was able to set up the subdomain to be used for the domain mapping plugin.

  • airfoil
    • Site Builder, Child of Zeus

    Yep. I've made no changes to the wildcard settings in our CPanel setup - and looking at it, it is still set to work with wildcards. This is a Psek hosting account.

    I'm a little hamstrung on this, since it is a production server.

    Any trouble shooting suggestions?

  • airfoil
    • Site Builder, Child of Zeus

    I'm completely baffled.

    I uninstalled Domain Mapping by deleting it from my mu-plugins directory. It is gone.

    However, my mapped domain still works.

    I can get to it directly, and by using the subdomain.

    Just to be sure something wasn't being cached, I tried it from multiple computers and browsers - including on separate networks and my iPhone. Still there.

    With the Domain Mapping plugin removed, when I create a new blog, all of the database tables appear (my earlier concern that tables were not being created was due to my phpmyadmin window not refreshing - my mistake) and it appears in my blog admin area.

    However, I am unable to access any new blog - frontend or backend. Just get a "Server not found" error.

    Wildcard DNS must be working, because the existing blogs can be accessed via subdomain. Just not new blogs.

    So...

    Issue #1 - why would domain mapping still be working with the plugin completely removed?
    Issue #2 - still can't figure out what could be causing new blogs to not be accessible?

    Again, any thoughts or ideas would be greatly appreciated.

  • airfoil
    • Site Builder, Child of Zeus

    Dr. Mike hit it on the head - it was really my screw up. All of our server DNS records for our various servers are managed at the host - at least I thought so.

    Due to some legacy applications, we apparently had our DNS records for this particular server managed at the registrar rather than the host.

    The WPMU install was done many months back, and only one subdomain had been set-up - and the A record apparently set at the registrar. So the issue had not come up since then.

    Long and short, because of this, setting wildcard DNS at the host wasn't really doing anything - needed to do it at the registrar.

    As always, I appreciate the assistance. Thanks.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.