Problem error with Infinite Seo

Hi, we are getting the attached error when activating Infinite SEO.

  • Timothy Bowers

    Hey there,

    set_time_limit is to allow for longer processing time, if you have a large site and a large sitemap it will take much longer to process.

    The warning is because your host is running in safemode. You would need to chat with your host about this.

    The plugin should still work fine, but if you do need more processing time and we can't extend it then could get timeout errors.

    Let us know if your host will change that, and which host it is.

    Take care.

  • Vinod Dalvi

    Hi @Mending,

    Thank you for your reply.

    We have set the time limit to manage longer processing time.

    You can just skip setting time limit by adding the following code in the wp-config.php file of your WordPress install but this will take a whole lot of time on big blogs.


    I have notified the plugin developer to change the code on line number 42 in the following Infinite SEO plugin file as below so that it won't display warning message in safe mode.


    Code to be changed :


    Changed Code:
    if (!(defined('WDS_SITEMAP_SKIP_TIME_LIMIT_SETTING') && WDS_SITEMAP_SKIP_TIME_LIMIT_SETTING) && !ini_get('safe_mode')) set_time_limit(120);

    Please advise if you have more questions.

    Best Regards,
    Vinod Dalvi