Problem installing the wpmu dashboard

I decided to get a local WP server working on my Mac for local development and learning purposes.
I am using the built in Apache server and I manually installed and configured the MYSQL database etc.
After some work I have WP working and next I needed to install the WPMU DEV Dashboard.
I downloaded the zip and installed the plugin - got all the way to logging into the MPMU server, then got the error message as per the screen shot shown.
Obviously I need some further setup of PHP, but could not find out how to do that and the error message only suggested I need to enable certificate verification - not sure what is needed there.
I don't know if it is just an addition to the .ini file, or something else.

Update: OK, so now I have made some possibly dubious progress - I added the following 2 lines to my WP-config.php file:
define('WPMUDEV_CUSTOM_API_SERVER', 'http://include.hout-atelier.nl/include.php?url=https://premium.wpmudev.org/');

define( 'WPMUDEV_APIKEY', 'YOUR-API-KEY');

The first line did not seem to do anything, but the second seemed to get me past the login screen.
But now it thinks I am a free member, so obviously I have still to be able to log in using my credentials,
so I suspect I am still at the same issue, but I thought I would let you know what happened from the above changes.

Will wait for your reply before trying anything else.

Could you please assist?

  • Predrag Dubajic

    Hey @Frank,

    Hope you're doing well today :slight_smile:

    I must say that I didn't use Mac built in Apache server but here are some things we can start of.
    Can you check that php_curl is enabled?

    Also, try adding this to your wp-config.php file before "That's all" message:
    define( 'WPMUDEV_CUSTOM_API_SERVER', 'https://premium.wpmudev.org/' );

    Let me know if this worked for you.

    Best regards,
    Predrag

  • Frank

    Hi Predrag,
    I checked that php_curl is enabled and it is, so that was OK.
    Next I entered your line, but I entered it as it came into my email and got a parse error,
    In my email the line translated to:
    define( 'WPMUDEV_CUSTOM_API_SERVER', 'https://premium.wpmudev.org/' );
    so then I had to think about it for a while and substituted ' for each ' occurrence
    - don’t know how that got translated in the email from your post, but then it worked, so thank you so much for the assistance.
    It has been interesting so far using the Mac built-in Apache server - I decided to use it as it was already there and I thought I might just learn some things along the way trying to use it.
    That has been true, but so far the only real things needing changing for me was the web root directory as I decided to go for /www from the root of the system disk to keep it simple and easy to find.
    And so far the only other issue I came across was the need for WP to use a local FTP server when installing a plugin, but I got over that with the following entry in my wp-config.php file:

    /** setup so we don't need FTP Server */
    define('FS_METHOD', 'direct');

    Again thanks for your assistance - hopefully all will work well now and I am off on a journey playing with WPMU new themes and plugins locally on my laptop - specifically I want to try out Wiki Pro.

    Kind regards,
    Frank Cottrell

  • Predrag Dubajic

    Hey Frank,

    Glad to hear this worked for you, I should also try fiddling with built-in apache server to see how it all works :slight_smile:

    Sometimes ' and other signs are not being formatted correctly in emails and even comments if they are not added in code tag, so I suggest always getting the code from thread itself or typing it manually to be sure everything is right.

    Have fun and let us know if there is anything else we can help you with.

    I'm going to mark this one as resolved but if you have any followup questions feel free to reopen it.

    Best regards,
    Predrag

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.