Problem: The Google Maps Plugin won't work

There's something wrong with the javascript console or whatever. I ran the minify tool which worked but I tried to turn on caching and it won't work. I get this error: http://d.pr/i/L2tL

thanks,

  • Adam Czajczyk

    Hello Jarod,

    I hope you're well today and thank you for your questions!

    It seems that you're asking here about two separate issues: a Google Maps plugin that's not working and the fact that you cannot enable the browser caching with Hummingbird. Since you already asked them here let's stick to this thread but it would be great if you could in future start separate tickets for issues if they are about different plugins :slight_smile:

    As for Google Maps!

    I visited your site but I can't see any Google Map there so I wouldn't be able to troubleshoot it that way. Could you please then elaborate a bit more on what's happening:

    - can't you enable the plugin or you can but it doesn't work?
    - if it doesn't work, are you getting any error messages?

    I'd also like to take a closer look at your setup so could you please grant me a support access to it using our WPMU DEV Dashboard plugin? Here's a guide on how to do this:

    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    As for an error shown on the screenshot attached to your post.

    Hummingbird plugin does not compress the site but it enables and configures compression that's performed by the server. This error message means that most likely a necessary server module is not installed or enabled on your server or it's not properly configured. I suggest that you start with getting in touch with your host and asking them about it. I think you could forward them the same screenshot as you attached to this post. In most cases host tech staff is able to enabled/configure compression module and that solves the issue.

    Let me know how that went, please.

    Best regards,
    Adam

  • Dimitris

    Hey there Jarod,

    hope you're doing good today and don't mind skipping in! :slight_smile:

    Google Maps now requires an api key to embed on your website even if you're using a plugin. It would be nice if Google could come up with something more helpful than "error".

    Please take a look in my reply here about GMap API :wink:
    https://premium.wpmudev.org/forums/topic/google-maps-no-option-to-add-map#post-1124989

    Hope that helps,
    Dimitris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.