Problem with Advanced theme switcher and Product Theme

There seems to be a problem with this advanced theme switcher plugin. While I was trying to test out some of the Buddypress themes at the base of the theme (footer), I am getting this error message

Warning: ksort() expects parameter 1 to be array, boolean given in /home/......../wp-content/plugins/advanced-theme-switcher/advanced-theme-switcher.php on line 260

Warning: Invalid argument supplied for foreach() in /home/......./wp-content/plugins/advanced-theme-switcher/advanced-theme-switcher.php on line 270

I noticed it once on a non-WPMUDev theme and twice on the WPMUDev theme Product Theme and one other one I cannot remember for now.

Please what do I do?