Problem with Appointments+ and CRED plugin (as of 1.4.5)

I'm using Appointments+, and have upgraded to 1.4.5. Doing so created conflicts with several plugins, including one called CRED (a premium plugin for doing front-end content creation). I would like to try and roll back to the previous version of Appointments+ to at least determine if the upgrade is indeed the culprit. However, I can't find a way to download previous versions no your site. Can someone point me in the right direction?

The specific problem is that Appointments+ seems to be conflicting with a shortcode that CRED uses to display messages at the top of the form.