Problem with automatic managed backups to The Hub

Hi,

I have a problem with automatic backup to The Hub.
It started yesterday at 22 o´clock, and now it says it still running.

This is from my error log:

[Cron][2017-02-11 22:15:31][Notice] Backup ready to start
[snapshot][2017-02-11 22:15:31][Info] Starting backup
[snapshot][2017-02-11 22:15:31][Info] Created the backup and added the queues
[Cron][2017-02-11 22:15:31][Info] Next process kickstart action scheduled for Sat, 11 Feb 2017 22:20:31 +0000
[Cron][2017-02-11 22:21:48][Warning] Immediate hook misfired, kickstart backup processing
[Cron][2017-02-11 23:21:20][Warning] Immediate hook misfired, kickstart backup processing
[Cron][2017-02-12 00:20:32][Warning] Immediate hook misfired, kickstart backup processing
[Cron][2017-02-12 01:20:37][Warning] Immediate hook misfired, kickstart backup processing
[Cron][2017-02-12 02:21:41][Warning] Immediate hook misfired, kickstart backup processing
[Cron][2017-02-12 03:21:27][Warning] Immediate hook misfired, kickstart backup processing
[Cron][2017-02-12 04:21:48][Warning] Immediate hook misfired, kickstart backup processing
[Cron][2017-02-12 05:20:32][Warning] Immediate hook misfired, kickstart backup processing
[Cron][2017-02-12 06:29:50][Warning] Immediate hook misfired, kickstart backup processing
[Cron][2017-02-12 07:20:37][Warning] Immediate hook misfired, kickstart backup processing
[Cron][2017-02-12 08:20:31][Warning] Immediate hook misfired, kickstart backup processing
[Cron][2017-02-12 09:29:05][Warning] Immediate hook misfired, kickstart backup processing
[Cron][2017-02-12 10:03:31][Warning] Immediate hook misfired, kickstart backup processing
[Cron][2017-02-12 10:21:27][Warning] Immediate hook misfired, kickstart backup processing
[Cron][2017-02-12 11:46:54][Warning] Immediate hook misfired, kickstart backup processing
[Cron][2017-02-12 12:27:17][Warning] Immediate hook misfired, kickstart backup processing
[Cron][2017-02-12 13:28:55][Warning] Immediate hook misfired, kickstart backup processing

Any idea why this happens? Thats a big site with a lot of images, but should that be a problem?

Best regards,

  • Dimitris
    • Support Star

    Hey there Mikkel,

    hope you're doing good and thanks for reaching us! :slight_smile:

    Let's follow some basic debugging steps here please. We'll try to increase the allocated to PHP memory, use smaller chunks of files and DB tables during snapshot backup process and enable WP_DEBUG to log any related error messages.

    Before doing so, please ensure that no manual backup is running and temporarily disable automated backups.

    Then please access your server through FTP edit the wp-config.php file, find a line like
    define('WP_DEBUG', false);and replace it with the followings (if the above line doesn’t exist, simply insert next snippet just above the /* That's all, stop editing! Happy blogging. */ comment)

    // https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP
    define('WP_MEMORY_LIMIT', '512M');
    define('WP_MAX_MEMORY_LIMIT', '512M');
    // Snapshot definitions
    // *Important:* the chunk sizes have to be fixed for each backup. So, if you'll be making use of this define, please make sure there's no manual backup running and temporarily disable automated backups.
    define('SNAPSHOT_FILESET_CHUNK_SIZE', 50);
    define('SNAPSHOT_TABLESET_CHUNK_SIZE', 100);
    // Enable WP_DEBUG mode
    define('WP_DEBUG', true);
    // Enable Debug logging to the /wp-content/debug.log file
    define('WP_DEBUG_LOG', true);
    // Disable display of errors and warnings
    define('WP_DEBUG_DISPLAY', false);
    @ini_set('display_errors', 0);

    Then go ahead and select the "Info" level of all debug levels in Snapshot -> Managed Backups and perform a manual backup (please keep in mind to don't close browser window) or enable the scheduled one.

    If you still get errors, a /wp-content/debug.log file should be created.
    Simply download it, rename it to debug.txt and attach it here in your next reply (if file is larger than 5MB, please use a service like Dropbox and post the shareable link instead).
    Finally, grant us support access to the website in question via WPMUDEV Dashboard plugin as described here https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-4

    Warm regards,
    Dimitris

  • Dimitris
    • Support Star

    Hey Mikkel,

    how are you today?

    Could you please share with us /wp-content/debug.log file? Simply download it, rename it to debug.txt and attach it here in your next reply (if file is larger than 5MB, please use a service like Dropbox and post the shareable link instead).

    Snapshot logs didn't show much, the backup process was halted while fetching files with no error messages. So I already performed another manual backup just in case this was a glitch (it's still running). I also activated the scheduled backups for tomorrow, so let's see how that will perform.

    Warm regards,
    Dimitris

  • Predrag Dubajic
    • Support

    Hi Mikkel,

    Thanks for debug log, however it looks like there are only couple of notices there that shouldn't be causing this issue.

    Can you try going to HUB page here https://premium.wpmudev.org/hub/ and click on backup icon next to site in question.
    Once backups tab opens click on View Key button and from there reset your API key.

    After that go to your site admin, and in Snapshot > Managed Backups enter your new API Key.
    Once that is done make sure to clear any server side caching you might have and see if the backup process finishes normally after that.

    Let us know how it goes.

    Best regards,
    Predrag

    • Mikkel
      • WP Core Meltdown

      Hi Predrag,

      I just try to do as explained.
      I was not able to make manual backup, there i got empty response.

      I have try to set automatic backup, this will start in around 45 minutes, and i think backup took around 2 hours last time i did it manual, so i will let you know, after some hours if it end up successfully.

      Best regards,

  • Adam Czajczyk
    • Support Gorilla

    Hello Mikkel!

    I just consulted one of the developers and that switch from http to https shouldn't be an issue as long as WPMU DEV Dashboard is connected to The Hub (and it is). I can see on the site that the backup is reaching some point and then it seem to stop and as it worked before - something on the site/server must have changed.

    While the http to https switch itself shouldn't be breaking that, we cannot yet exclude it entirely and also there may be some related issue that is affection it. Can you recall if there were any additional changes to the site related to that switch and/or any other changes right after backups stopped working?

    I also think that at this point a full conflict test might be helpful as it may point us towards some conflicting code/plugin. Could you please perform it? To do this follow the steps from a flowchart in this article:

    https://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    Let us know about results, please!

    Best regards,
    Adam

    • Mikkel
      • WP Core Meltdown

      Hi Adam,

      This problem happens on two different sites.
      One is single wp site and other one is a multisite.

      The only change i made for both of them is set up SSL.
      I have a lot of other sites running on same server as these sites, so i think that the idea about problem with server is not right here, while then other sites should fail too.
      But as mentioned before, both sites have big backup files, one of them around 800 mb and other around 160 mb. And must of the other sites is just small ones at 30-50 mb.

      BR

  • Dimitris
    • Support Star

    Hey there Mikkel,

    hope you're doing good today! :slight_smile:

    Could you please try to exclude these large files from snapshots and test if that makes any difference? You can do so via Snapshot -> Settings -> Global File Exclusions

    Let me know know about your results!
    Take care,
    Dimitris

  • Mikkel
    • WP Core Meltdown

    I have now try to disable plugins and clean up my db.

    Im now able to take manuel backup of multi site install, and waiting to see if automatic backups will success too.
    The single install i did same things, but was still not able to make manual backup, it stopped this time around step 191, so longer than before. Now i will wait and see if automatic backup can work.

    I will update you tomorrow about the result.

  • Mikkel
    • WP Core Meltdown

    Hi,

    Finally it worked again.
    To night both the single site and multisite was able to automatic backup!

    Im not sure what make the problem.
    But i think that maybe WP Rocket made the problem for me.

    Thank you for your support!

    Best regards,

  • Dimitris
    • Support Star

    Hello Mikkel,

    I trust you're doing good today!

    I have now try to disable plugins and clean up my db.
    ...
    Im not sure what make the problem.
    But i think that maybe WP Rocket made the problem for me.

    If you could share some more info on this it would be awesome for future reference!
    Haven't you excluded/deleted any large files at all?
    Which plugins did you disable? Or was it WP Rocket only?
    Please advise! :slight_smile:

    Warm regards,
    Dimitris

    • Mikkel
      • WP Core Meltdown

      Hi Dimitris,

      Sure i will share with you, as soon that im sure what actually fixed my problem.
      I will do some test over next days, where i try to activate plugins that still not activated, like WP Rocket and Advanced Database Cleaner.
      Then when i see that backup fail i can be 100% sure. As mentioned earlier the sites is a bit big, so manual backup take a lot of time, so will have to wait for automatic backups over the next days.

      Best regards,

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.