Problem with browser caching

I tried to enable browser caching but it doesn't work. Have tried it inserting manually in .htaccess but without success. And the problem is because I don't have access to httpd.conf (http://stackoverflow.com/questions/34252798/how-to-update-httpd-conf-file-in-openshift)
Is there an alternative way to enable it?

  • Paolo
    • New Recruit

    running httpd -l returns following result:

    httpd -l
    Compiled in modules:
      core.c
      prefork.c
      http_core.c
      mod_so.c

    I suppose here should also be listed "mod_expires.c"?
    Guess nothing from browser caching with my current hosting.

  • Nastia
    • Support Rock Star

    Hello Paolo

    Welcome to WPMU DEV Community!

    Do you see any message at Hummingbird > Browser cache when you are trying to activate it?

    What server you are on, Apache or Nginx? You can see this, once you install the WPMU DEV Dashboard plugin from WPMU DEV > Support > System Info > Server tab.

    If you do not have access to the httpd.conf, would you please contact your host provider and ask to make these modifications for you?

    If its okay for you then please grant support staff access so I can take a closer look. You can grant access from WPMU DEV > Support > Support Access > Grant Access or see this manual.

    Let us know how it goes!

    Cheers,
    Nastia

  • Paolo
    • New Recruit

    Hi Nastia,
    thank you for your reply. I am getting te error "Your server may not have the "expires" module enabled..."
    It's Apache server, but I am hosting it on Openshift and they don't give a support for this kind of customization. The only way to enable it is to add custom cartridge where you can have more permissions but that requires manually adding MySQL, php, connecting them with env variables and in that way you need to manually update those cartridges so I am trying to avoid that.
    I granted the support access. Is there any other way to set expires headers?

    Regards

  • Nastia
    • Support Rock Star

    Hello Paolo

    I hope all is well!

    I have logged in to your site, but the Hummingbird plugin wasn't enabled. Please note, that your PHP version is 5.4, WordPress recommends to use PHP 5.6.

    Would you please manually edit your site's .htaccess, and remove the lines of code starting from this:

    # BEGIN WP-HUMMINGBIRD-CACHING

    And ending with this:

    # END WP-HUMMINGBIRD-CACHING

    And try to enable the browser cache again?

    Let us know how it goes,

    Cheers,
    Nastia

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.