Problem with Domain Mapping accepting domain

I'm having trouble with mapping a domain... I know that it has propogated, because when I enter the domain name, it goes to the correct IP address. I know that I correctly have the a record set to the ip. However, I still continue to get the error that the domain name is unavailable. The documentation for the plugin says that this indicates an issue with the domain dns setup. But I can't figure out what can be wrong. The a record would override whatever I have in the name server area, correct? Can someone please help me? I'm willing to give my godaddy access if necessary or my host info. Whatever... I'm just hoping I can get this fixed soon.


  • PC
    • WPMU DEV Initiate

    Hey there @warpedmind

    Thanks for posting on the forums.

    Can you kindly provide me access to your site ? You can enable support access via :

    WordPress Dashboard >> WPMU DEV Dashboard >> Support >> Staff Access >> Grant Access.

    If you have not installed WPMU DEV Dashboard plugin yet, kindly do that here : and then allow access as per the above process.

    Also please provide me the domain name to be mapped and the IP of your network site.

    Please advise.

    Cheers, PC

  • warpedmind
    • The Incredible Code Injector

    Haha PC! Your name was @pc before and now you're @Mac! I'm glad you joined us Apple people! :slight_smile:

    The ip is I've granted you access to my site... it is (which you've been helping me with)... but the site in question with the mapping issue is

    I know that has propagated, at least as far as the servers my browser is hitting.

    Thanks so much!


  • Ash
    • WordPress Hacker

    Hi @warpedmind

    I hope you are well today.

    First of all, is is a dedicated IP? It needs to be a dedicated IP.

    If yes, the IP should point to the directory of wordpress root. That means, if you enter the IP in the browser, you should see the site

    Please confirm.

    Hope it helps :slight_smile: Please feel free to ask more question if you have.


  • warpedmind
    • The Incredible Code Injector

    @ashok, thanks for your follow up. I talked to my host, wpengine. This is what they said:

    I'm not exactly sure why a dedicated IP is needed for this plugin. I do see that on this page -- -- they say that a dedicated IP is needed so that when you navigate to the IP, you'll see your multisite. While you do have a dedicated IP for, you still won't see your site when navigating to the dedicated IP due to our server configuration.
    If it's necessary that you're able to see the site when navigating to the dedicated IP then I would recommend looking for another plugin that would suit your needs, as our platform does not behave that way.
    I tried to see if there was any way for me to reply to the thread you have going in the link you sent, but it looks like I'd need to pay for their services in order to interact on the forum. If you'd like, you can reply back to that thread and confirm that is a dedicated IP. I would also mention that you will not see the site when navigating to and you will instead be served a WP Engine 404 even though it is a dedicated IP.
    I'm curious as to why a dedicated IP is required though, as that's not a common requirement for a plugin. Would you be able to reply back to that thread to confirm that is a dedicated IP? Additionally, you could ask why the dedicated IP is necessary, because if it ultimately wouldn't be necessary on our platform then we could put you back to the server's shared IP and you could get a refund on your SSL.
    Since we can confirm that you're on a dedicated IP, WPMU DEV should be able to provide further guidance. If there's anything I can do to help from our end, please let me know!

    Does this help? Can you please give me a reply for wpengine, if it is necessary? I hope that you can figure this out.



  • Patrick
    • Support Monkey

    Hey there @warpedmind

    I hope you are well today!

    A dedicated IP is not necessarily required by the plugin, as can be seen in the "More options?" section on the usage page here:

    However, if you need to map a top-level domain ( to a sub-site in your multisite network, without using an addon or parked domain, then your multisite must be on a dedicated IP for mapping to work. If it's on a shared IP, mapping will point to your host's default page, not your multisite.

  • warpedmind
    • The Incredible Code Injector

    @Patrick Cohen, @mac, @Ashok...

    Ok, I'm confused and frustrated. Thanks for your replies... but I need some clarification and some follow-through please. I have you guys jumping in really quick on this case, but then that's it.

    Regarding the last comment of whether or not the dedicated IP is needed, I see this on the same referred link:

    Dedicated IP: For using A Record setups, you need to ensure you have a dedicated IP. This IP would fall onto your multisite setup. i.e. when you enter the IP you see your multisite.

    My domain is using an A record setup, as it is with WPEngine and that's how they wanted it set up.

    If one of you guys could please read my intentions below and then PLEASE look at my site (see above) and help me, I would really appreciate it. I appreciate all your input... but so far, I've had 3 different support people participate in this thread, but I'm still here waiting to know what to do next. This is what I'm trying to do:

    My multi-site domain is I am using pro sites, etc... I want it to be a place that people can create their own sites off of. I want the customers to be able to point their own domain names to the location as well. For example, the site I'm trying to add now is so I'd like it to work that if I visit, it will take obviously work the same as if I visited

    That doesn't work. I'm under the impression that I do indeed need the IP address for my instance. If I'm wrong, then please tell me, but according to the documentation mentioned above, I need it (to my understanding). Please also note my comments from WPEngine about why going to the ip address ( does NOT lead me directly to the website.

    I'm very confused and frustrated.

    Can someone please take ownership of this case and help me? If necessary, can you speak directly with WPEngine so that you all are on the same page?

    Thank you for your help. I look forward to your reply and solution. Let me know if you need anything else... but you have access to my site. I just want a definitive look and solution to my problem. I appreciate all of your help so far... but can someone please help me close this up? I'm very frustrated... I've been working on this site since last year (My target to LAUNCH was November!) and I've had so many issues. I'm very disappointed so far in how all this is working out. I BEG you guys to help me finish this by helping me address these issues... I'm almost there! I'm paying $100 per month for WPEngine and it's killing me... I really need to launch soon.

    Thanks again. Sorry for complaining. I appreciate you guys.



  • aristath
    • Recruit

    Hello again @warpedmind, I hope you're well today!

    First of all, I'd like to appologise for the confusion on this thread. I have called-in the plugin developer on this one, hopefully he'll be able to help us further.

    This plugin depends completely on the server's configuration.
    Let me just post some examples, they might help you understand what is going on:

    Case 1: VPS without cPanel/plesk etc:
    If you have a VPS without cPanel, you can configure your apache or nginx server to point all incoming traffic to your webroot folder where you have your WordPress installation. Once the webserver points a visitor to your WordPress installation, the plugin then takes over and serves the right blog from your network of blogs and takes care of any rewrites.
    In this case, a dedicated IP is not necessary since you can directly configure your webserver from an SSH terminal.

    Case 2: VPS or shared hosting with cPanel/plesk etc:
    In this case, a dedicated IP is necessary because the control panel takes over control of your webserver and it's not that easy to configure the webserver to point all incoming traffic to your webroot. That's why a dedicated IP is necessary... by using the dedicated IP, you sort of get around the cpanel's limitations.

    With that being said, it is not necessary to have your site appear when you enter the IP on your browser.
    BUT when you point a domain's A records to your IP, you should be getting your site. If not, then there must be a way for WPEngine to point all incoming traffic from your dedicated IP to your webroot.
    I'm sure they have their reasons for not doing so, but if that doesn't happen, then there's absolutely no way to have a plugin like this properly working. And I'm not just referring to this particular plugin, but all similar plugins.

    I personally have 5 VPSs that manage and have everything setup perfectly fine without using a dedicated IP. But I did have to properly configure my webserver to point all incoming traffic to my WP site.

    I'm not a sysadmin so I don't know all the ins and outs, but from the little I know and understand WPEngine will simply have to tweak your configuration a bit.

    I hope that clarifies things a little!

    For more details I'm sure the plugin developer will be here soon and shed some more light on this.


  • warpedmind
    • The Incredible Code Injector

    @Sam, @aristath,

    I tried it with the Verify DNS set to No, as well as Yes. The good news is that I am now getting the message at the top of:

    Looks like we are able to resolve your DNS A record(s) for your main domain and fetch the IP address(es) assigned to it. You can use the following IP address(es) to enter in the Server IP Address field below:

    However, this doesn't seem to be working still. I have the domain name, which is supposed to resolve to This still is not the case. I do have the A record for pointing to the ip.

    You have access to my site can you please help me resolve this finally?

  • Sam
    • The Incredible Code Injector

    Hi @warpedmind

    I just went there, set "Verify domain's DNS settings" to "No", added for and now everything seems to be working without any problem.

    Please check and confirm.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.