Problem with domain mapping, domain with and without www

Hello, we recently updated WP and domainmapping to the latest versions, after this we have problem with domain not redirecting to selected primary domain

As an example, if you enter in browser "vinci****.cm**.se" (the network domain), it forward correctly to "www.vinci***.se", but if you enter "vinci****.se" as domain, it will not forward to http://www.vinci****.se.

  • Luís
    • Support

    Hi Jimmy ,

    Hope you're doing well today!

    Firstly, I marked this topic as "internal" to remove the public visibility and to protect the privacy of the information shared here. Only you and the Support team will be able to access to this topic. If you don't mind, I can swap the visibility to public again.

    After further investigation, seems that is WPML that is conflicting with Domain Mapping for some reason. In your network, the subsites I checked where is not redirecting to the primary domain assigned, have WPML enabled.

    As an example, can you try:

    1) go to vincivinci.se , disable WPML and clear the cache;

    2) In a private window (to avoid any cache or cookies), try "vincivinci.se", it will properly redirect to the primary domain, in this case " http://www.vincivinci.se".

    I tried to replicate the issue on my site, but honestly, was not able, maybe because I don't have the same WPML version. Do you have the chance to update WPML to the latest version (3.9+), to check if the issue stills?

    If not or if the issue stills with the latest version, can you send us the FTP access to your site, so we can investigate further? Please send it privately through our contact form:

    https://premium.wpmudev.org/contact/#i-have-a-different-question

    Send in:
    Subject: "Attn: Luis Lopes"
    - WordPress admin username
    - WordPress admin password
    - Login url
    - FTP credentials (host/username/password)
    - Link back to this thread for reference
    - Any other relevant urls/information

    Cheers, Luís

  • Jimmy
    • WPMU DEV Initiate

    Hello,

    Nice find, it actually worked when disable WPML, but even with latest version of WPML installed, redirect is not working when WPML is active :slight_frown: i tired to clear cache and wpml cache also with no success

    Let me arrange access for you tomorrow if you dont want me to try anything else with WPML, im at home currently.

  • Ash
    • WordPress Hacker

    Hello Jimmy

    I think there might be any specific settings that we are not using, so we are not able to replicate the issue on our sides.

    I have also seen lots of conflict with WPML with Domain Mapping in their support forum, so there might be a limitation. Did you get a chance to contact WPML support if they can suggest something? Maybe there is a setting tweak that may fix this.

    Please let us know if you get anything back from them. Have a nice day!

    Cheers,
    Ash

  • Jimmy
    • WPMU DEV Initiate

    Hello,

    I received this answer from the guys over at wpml

    At this point, I would need to ask you to share with me the latest version of the DOMAIN MAPPING plugin by 'wpmudev' so I could test this issue on a clean and fresh multisite installation. Then I would be able to present it to our compatibility team, and they will try to find a fix for that. Please know that a cooperation from the author of the plugin might be needed at a certain stage. It would be great if you could contact the authors and urge them to join our Go Global Program. You can find details about it here. https://wpml.org/documentation/theme-compatibility/go-global-program/ We will be happy to cooperate with the authors in making their plugin officially compatible with WPML.

    Please let me know if they may receive a copy of your plugin, and they seem to be willing to make it compatible, hope to hear from you soon.

    /J

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.