Problem with domain mapping - health status invalid

Help! I have been using domain mapping on this network with Cloudflare for almost 2 years and have many domain mapped sites successfully setup using the CF SSL. Unfortunately, I have a site that we processed yesterday that I am still getting an invalid health status. The propagation was complete and Cloudflare has issued SSL. All settings at CF are the same as the other sites. I'm at a loss at how to trouble shoot this problem. It is important that her site be up today!

  • Dimitris

    Hey there antKat,

    hope you're doing good and thanks for reaching us! :slight_smile:

    I just inspected your settings as you've kindly granted support access for us and I noticed that both DM settings in network admin area labeled Verify domain's DNS settings and Check domain propagation before mapping are set to NO. :thinking:

    Could you please point to us the subsite and domain name in question?

    You could use the support notes area in WPMUDEV -> Support to share this info instead of our publicly available support forums here. :wink:

    Take care,
    Dimitris

  • antKat

    Hi Dimitris,
    Thank you for your response. I have adjusted the settings you suggested but to be honest, I had checked the propagation and CF had been showing an active cert before I tried domain mapping the site.

    I believe the problem was with the CF universal SSL cert, because after total frustration this morning I upgraded to a paid cert and it instantly resolved.

    The only other thing that I noticed that seemed odd is that on the domain mapping settings page, the server IP addresses that the plugin is finding is not our IP. I had inserted the correct one but was wondering where the plugin is picking up the wrong one from.

  • Adam Czajczyk

    Hello antKat!

    Thank you for letting us know about the CF issue. Since you already handled this one, let us know please in case that happened again.

    As for an IP. Since the site is behind CloudFlare, Domain Mapping may be picking up CF's IP instead of your server's IP. That's not quite an error because neither Domain Mapping script nor the WordPress itself is able to "read server settings" directly so the IP that's detected is the same that would be resolved "from outside". That doesn't actually matter much as it's mostly use for informational purpose so it should work fine even if you didn't update it :slight_smile:

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.