Problem with domain mapping + nginx (www to non-www redirection)

I've setup nginx (no apache) on my VPS and this is the issue I'm dealing with:
When a users enters a domain on the domain mapping plugin, it only works without the www. What would I need to do to get redirect ALL www domains to non-www ?

Thins is my nginx configuration file:

server {
    listen       80 default_server;
    server_name  openstores.gr *.openstores.gr;
    root         /home/marketplace/sites/www.magazi.org/public_html;

    access_log   /home/marketplace/sites/www.magazi.org/log/access.log;
    error_log    /home/marketplace/sites/www.magazi.org/log/error.log;

    location / {
        index index.php;
        try_files $uri $uri/ /index.php?$args;
    }

    # Add trailing slash to */wp-admin requests.
    rewrite /wp-admin$ $scheme://$host$uri/ permanent;

    # Directives to send expires headers and turn off 404 error logging.
    location ~* \.(css|less|js|png|jpg|jpeg|gif|ico)$ {
        expires 240h;
        log_not_found off;
    }

    # this prevents hidden files (beginning with a period) from being served
    location ~ /\.          { access_log off; log_not_found off; deny all; }

    # Pass uploaded files to wp-includes/ms-files.php.
    rewrite /files/$ /index.php last;

    if ($uri !~ wp-content/plugins) {
        rewrite /files/(.+)$ /wp-includes/ms-files.php?file=$1 last;
    }

    # Rewrite multisite '.../wp-.*' and '.../*.php'.
    if (!-e $request_filename) {
        rewrite ^/[_0-9a-zA-Z-]+(/wp-.*) $1 last;
        rewrite ^/[_0-9a-zA-Z-]+.*(/wp-admin/.*\.php)$ $1 last;
        rewrite ^/[_0-9a-zA-Z-]+(/.*\.php)$ $1 last;
    }

    location ~ \.php$ {
        client_max_body_size 25M;
        try_files      $uri =404;
        fastcgi_pass   unix:/var/run/php5-fpm.sock;
        fastcgi_index  index.php;
        include        /etc/nginx/fastcgi_params;
    }
}

I'm no nginx guru so any help would be appreciated..