Problem with Easy Blogging continually redirecting for administrators

I have the wizard activated and am aware that you can exit wizard mode, however most people are not going to click that since the last option in the wizard is to visit their new site. The major problem I am having is when they try linking back to an admin page.

I have my URL's setup like this: /wp-admin/post-new.php?wdeb_on?wdeb_wizard_off

The goal of the url is to exit the wizard mode and stay on the same url without being redirected to index.php. This method works when logged in as a Network Admin, however for site administrators it redirects back to the wizard.

Please advise on a solution.

  • Vinod Dalvi

    Hi Jason,

    Greetings and thanks for posting on the forums.

    I have tested it on my test site using latest version of Easy Blogging plugin and WordPress multi site 3.8.1 and it worked fine without any issue for both Network Admin and administrators .

    Is there anything that i have missed?

    Please advise.

    Would you mind if I logged in to your site and did some testing? This might help get to the bottom of this faster. If this is ok, just grant me temporary admin access to your site by clicking "Grant Access" button in the WPMU DEV Dashboard Settings from the following path and reply on this thread after granting it?

    Admin -> WPMU DEV -> Support -> Support Access Tab

    Kind Regards,
    Vinod Dalvi

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.