Problem with google maps install

My client is hosted on goDaddy. I wish this was not the case but it is.

Anyhow, I am getting this error with the google maps plugin from WPMU.

Parse error: syntax error, unexpected T_STATIC, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in /home/content/r/a/j/rajsdoshi/html/wp-content/plugins/wpmu_dev_maps_plugin/lib/class_agm_plugin_installer.php on line 30

I have also attempted to install a different google maps plugin. I get the same basic error.

Called the support and they said they don't know. GoDaddy said they are running php5 and that I should ask some folks if maybe there is some kind of dependency issue?

John

  • DavidM
    • DEV MAN’s Mascot

    Hi imagineutopia,

    That does look to be a PHP 4 issue. Could you give the following a try?

    1. Create a blank file, name it phpinfo.php and paste in the following:
    <?php phpinfo(); ?>

    2. Place that in the WordPress folder and point your browser to that file (domain.com/phpinfo.php)

    Could you give that a try and let us know what the PHP version yields with that?

    Thanks,
    David

  • DavidM
    • DEV MAN’s Mascot

    Yes, definitely you can imagineutopia. I imagine you can ask them to upgrade it as well, hosts often will accommodate that request. It's only reasonable since WordPress 3.2 is right around the corner (perhaps 1 month away) and will require it.

    That should take care of it for sure, though.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.