Problem with Login caused by Domain Mapping

I have a multi-domain subdomain network with domain mapping

I added a new admin user and trying to login I get a really odd error, and now anytime I log for any user, including super admin, the same error persists for subsites and the main site.

after a bunch of testing I deactivated Domain Mapping plugin Version 3.0.8.1 and the problem went away, reactivating Domain Mapping brought it back

I tested changing domain mapping settings for administration and login mapping, no luck

subsite.mainsite.com/wp-admin/ or wp-login.php

subsite.com/wp-admin/ or wp-login.php

mainsite.com/wp-admin/ or wp-login.php

from the login page I enter the user and password and it hangs up with a really long URL — but if I open a new tab and browse to the login page the dashboard loads, I guess the cookie is loading but not finishing loading the page upon login

where it gets really strange is in Internet Explorer, hitting the Login button or enter after the password – loads a blank CSS file in Dreamweaver (my default editor) – the CSS file has a very long file name and changes each time

I reinstalled WordPress 3.4.2 from the admin dashboard, updated the network, cleared cookies in IE and Firefox browsers – same results (in browser where cache not cleared access to dashboard without logging in okay), I tested in a subsite with basic twenty-eleven theme, I disabled/enabled single signon in multi-domains plugin

For sure Domain Mapping is the culprit, not sure if it is conflicting with other plugins or something to do with the recent update.

  • tripvendor
    • The Bug Hunter

    Alyeska Theme framework, but tested on twenty-eleven

    MANY plugins — However, I disabled ALL OF THEM… activating only Domain Mapping…

    I tried Admin and Login Settings as both “domain entered by user” and ‘mapped domain’ and they both resulted in the Log In page generating a ” Internet Explorer cannot display the webpage ” after entering User ID/Password — No other plugins enabled at all

    Operating System : Linux

    Server : Apache/2.2.22 (Unix) mod_ssl/2.2.22 OpenSSL/0.9.8e-fips-rhel5 mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635

    Memory usage : 64.15 MByte

    MYSQL Version : 5.1.65-cll

    SQL Mode : Not set (info)

    PHP Version : 5.3.10

    PHP Safe Mode : Off (info)

    PHP Allow URL fopen : On (info)

    PHP Memory Limit : 256M (info)

    PHP Max Upload Size : 128M (info)

    PHP Max Post Size : 128M (info)

    PHP Max Script Execute Time : 600s (info)

    PHP Exif support : No (info)

    PHP IPTC support : Yes (info)

    PHP XML support : Yes (info)

  • S H Mohanjith
    • Developer

    Did you remember to remove the sunrise.php after deactivating domain mapping plugin?

    You can download the previous version by clicking ‘Download’ link on the right hand of this thread and then clicking ‘Older Versions/Changelog’ and clicking on ‘3.0.8’ for now .

    Thanks!

  • tripvendor
    • The Bug Hunter

    while I was stomping around my garden trying to blow off some steam, cutting off the heads of flowers, kicking rocks and helping my dog chase the neighbors cat … it occurred to me that I could simply roll back to an earlier version and I didn’t need to restore my network, thanks for the suggestion

    however, unbelievably it still isn’t working… login just empties the user and password

    in admin settings it won’t save to “domain entered by the user” and bounces back to “mapped domains” which is a sign of something wrong for sure

    I am now going to uninstall multidomains and domain mapping, reinstall older version

    then cut down some trees and burn the barn

  • tripvendor
    • The Bug Hunter

    it’s completely useless

    I deleted multidomains and domain mapping – through admin and hunted files

    I re-installed 3.0.8 and could not log in, and could not save Domain Mapping admin settings

    I unistalled that and re-installed 3.0.7 including the sunrise file

    same thing — settings not saving, can’t log in

    is there something in the database?

  • tripvendor
    • The Bug Hunter

    ummm… would you like to login? (insert hysterical laughter here)

    logins not working, even for main site now

    the network appears to be having some kind of meltdown

    I upgraded Domain Mapping back up to 3.8.1 through the plugins admin — still would not save admin / logging settings

    I deactivated Domain Mapping, but could not log in… before when I deactivated it I could log in — behavior is somewhat different than earlier today… it is clearing the user/password fields rather than hanging up on page load

    also a very troubling development has come up where Bulk Actions are no longer working in plugins admin

    my error log has ballooned and I’m going to look through that for more clues while I manually deactivate all plugins

    if I can’t figure out how to do a log in to even the main site I’m not sure what will happen next

  • tripvendor
    • The Bug Hunter

    Thank you for the support

    titanic level crisis averted, the iceberg zigged, we zagged

    I manually deactivated all the plugins that aren’t actually required to display the pages. for the third time, I deleted Domain Mapping for the 435th time today… reinstalled 3.0.8 and now logins are working

    the error log is packed with stuff from some plugins which look to be the blame for the whole darn thing.

    I did deactivate ALL of them early in the process but apparently I was taking the wrong steps in reactivating plugins and testing log ins

    I apologize if I caused extra work for you here, but I thought for sure deactivating them would do it… now it appears to be half way there.

    tomorrow I will reactivate them one by one – and if anything related to WPMUDEV plugins I’ll let you know.

    I’m going to mark this resolved even though I reserve the right to panic later

    Regards

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.