Problem with marketpress plugin

Hi

The product pages are showing weird page names and other unwanted content - see screenshot attached. We are using a WPMD theme so the integration should be good.

Thanks for your support

  • Luís

    Hi Anthony Nec ,

    Hope you're doing well today!

    This bug was already reported, it's related to the use of custom menus in Upfront. Sorry for the inconvenience, but our developers are aware and working to fix it asap.

    Meantime, I can only suggest you to recreate the menu in the Upfront editor, removing all the items and add them again.

    1) Click in your menu settings (gear icon);

    2) In the left panel, remove all items and add them again.

    I hope this information has been helpful. If I can help you in this or other questions, please let me know!

  • MrArtist

    I've been getting the same issue and happened on this ticket by chance.

    I'm just about to rebuild my menus on a new install of a site (with Upfront and MarketPress) so It's perfect timing if you can answer the following:

    Is the problem best avoided by only building menus via Upfront? Or are you implying this "may" solve the problem? - i.e. Is this issue caused by building menus in WP rather than Upfront, additionally, is this just a "sometimes" or "always" bug via WP and/or Upfront?

    Thanks.

    • Luís

      Hi MrArtist ,

      Hope you're doing well today!

      From what I tested, the best option should be build the menu in Upfront. The issue happens when we create a custom menu in WordPress via Appearance -> Menus.

      I shared this solution with a few members and it solved the issue for all of them.

      I should mention that, the above solution is a "temporary" fix to correct this behaviour, our developers are aware and it should be fixed in the next Upfront releases.

      I hope this information has been helpful. If I can help you in this or other questions, please let me know!

      Cheers, Luís

  • Anthony Nec

    There is also another problem as you can see from the above screenshot:-

    there is a date showing that has no relevance to the product, I guess it's the date the post was created. However as our product is a training event on a different date, this is very confusing to customers - can we remove this feature?

    We didn't have these problems when we used another WP theme.

    We only have them now with UPFRONT which is a WPMD theme. I'm very surprised and frustrated that there is such poor integration between this WPMD theme and plug-in...

  • Luís

    Hi Anthony Nec ,

    Hope you're doing well today!

    Sad to hear the problems you are having. Our developers are working in a better integration between MarketPress and Upfront.

    Regarding to the menu, I checked your website, and I think you already solved that issue.

    To remove the date in the single product page, please add this CSS code to Global Theme CSS:

    .post_date {
      display: none;
    }

    1) In the left panel, expand the "Theme Settings" section and click in "Global Theme CSS";

    2) Add the above CSS code in the CSS editor;

    I hope this information has been helpful. If I can help you in this or other questions, please let me know!

    Cheers, Luís

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.