Problem with Multi-db setup.

Hello,

This is

I'm installing multi-db. I have configured the files and uploaded them where they are required. On navigating to "move-blogs.php" via my browser, I am met with the following error:

DB Error, could not list tables
Make sure you configure your original table in the dbname variable at the top of the script!
MySQL Error: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '-a-wor-449' at line 1

What is this "original table" in the dbname variable? I thought that the dbname variable was supposed the contain the original database name - that's what it says in the comment by the side of it. The fact that the variable IS called dbname also indicates it.

Please help. Thank you.

Regards,
Stephen

  • PC

    Hiya @sonnymanou

    Greetings.

    I just noticed that you responded to the post notification and that is why your response was not posted here.

    I have posted it here so that @Jack Kitterhing can help you resolve the issue.

    Hi Jack,

    Thanks for your reply.

    After reading through the thread you've supplied to me, I found that the "grave" character did hold me back initially. Things are not plain-sailing though; I still have some hoops to jump through. The next error is just as insurmountable for me.

    Here it is, followed by things I've done to try to fix it.

    Houston, we have a problem!
    Looks like you need to create your new db's! If you're lucky, this link still works - click me
    Database Error: Access denied for user 'web95-a-wor-449'@'%' to database 'web95-blirrtyc'

    This is what is in the central table:

    Tested on PHP 5 & MySQL 5
    Make sure all of your new db's exist (green text next to table name in db column below)
    In the status section, each table should show not in new db (unless you've already run this script)
    To start the copy process click here
    Be patient, depending on how many blogs you have, this could take a while
    Once completed, refresh this page by clicking here
    Check to make sure that in the status section all tables say table in new db
    Rejoice, I probably just saved you hours of your life!
    If this didn't work, don't blame me. Sometimes life is just like that..
    There is no information from any databases listed after the above notice.

    You'll notice that there is a hyphen in the new databases also. I added the grave character to all sixteen databases, their usernames and the passwords also.

    Similar result.

    I then removed the grave character from the passwords, and then the usernames and then fianally the database names to arrive back at the same error above.

    I've tried the links that are displayed after a refresh and the first one says that I cannot access content to that forum via the IP address. The other two don't work either.

    Obviously, I'm not that clever with this stuff. I can, however, put together complicated flat-packed furniture after reading the instructions. I can put together a club elliptical machine without instructions. I'm not thick, but I'm not getting this either.

    Any further help that you can offer would be appreciated.

    Best regards,
    Stephen.

    Please make sure that you do not reply to the post notification but come to this post for posting any replies.

    Cheers, PC

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.