Problem with pro site not showing upgrade

Hi can you help iv installed pro sites and set it up as like the help manuals however im not seeing a upgrade account on my site or back end, can you check things out for me in my admin to make sure its set correctly cheers !!!

  • Tyler Postle
    • CGO

    Hey Carl,

    Hope you’re doing well today!

    You won’t see the upgrade button on your main site, but if you create a new one you will :slight_smile:

    I see in the Pro Sites > Settings you have turned off the admin bar upgrade button but you still have the admin menu upgrade button on, so there will be a “Your Account” menu item on the dashboard menu for subsites.

    It looks like your Pro Sites checkout might be using a page you didn’t intend for it. If you go to Pro Sites settings and click “Edit checkout page”, is that the page you want for your checkout page?

    If not, then delete that page and make sure it’s removed from trash bin, then re-save your Pro Sites settings – that will create you a new checkout page.

    If you want to keep the content on that page, just copy it and then re-create the page after you have a new checkout page.

    Hope that helps!

    Let us know if you have any further questions.

    All the best,

    Tyler

  • Tyler Postle
    • CGO

    Hey Carl,

    Thanks for your reply!

    I just noticed that it's not selecting posts, it's selecting jobs, a custom post type that appears to have come with your theme.

    Can you temporarily swap to the default 2015 theme and then check if the checkout is working properly? I'm thinking this is a theme conflict.

    As for creating new sites, you can do that from this link: domain.com/blogs/create

    I have attached a screenshot illustrated how you can there while logged in too.

    Hope that helps!

    Cheers,

    Tyler

  • carl
    • Site Builder, Child of Zeus

    @tyler Postle when i clicked on the link create new site as show in your screenshot again that took me to a post from my site so i switched to the 2015 theme and i got this ( Oops! That page can’t be found. ) so not sure whats wrong here and when i clicked on the link in your reply above that also gave me a page not found so im confused again !!!

  • Tyler Postle
    • CGO

    Hey Carl,

    Yes, the Pro Sites checkout page on the backend will just be blank, you can add content to it and that will display on the frontend above the level selection and checkout :slight_smile:

    The checkout page has dynamic content, so even though it looks empty on the backend, it will still show everything on the frontend.

    when i clicked on the link create new site as show in your screenshot again that took me to a post from my site so i switched to the 2015 theme and i got this ( Oops! That page can’t be found. ) so not sure whats wrong here and when i clicked on the link in your reply above that also gave me a page not found so im confused again !!!

    Make sure that you set a page for your BuddyPress “Site Directory”, just create a blank one called anything you like and use that.

    you can set this via:

    Settings > BuddyPress > Pages. From your main site. That should fix the issue :slight_smile:

    Hope that helps!

    Cheers,

    Tyler

  • carl
    • Site Builder, Child of Zeus

    @tyler Postle can you help with this problem when users click to upgrade there account there is a error message if you go on my site and in the header menu click post new or blog and below that menu you will see the main menu in blue, so if you hover on upgrades then hover on create site click upgrade site and you should see the error message users are seeing how do i resolve this ?

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.