Problem with Pro-sites and Paypal Express Checkout

I'm having an issue with Prosites and Paypal Express Checkout.

I currently have the site functioning using the Stripe sandbox option however, I'd rather not have to set up an SSL certificate for this domain name - (required when using Stripe) - if I don't have to at this point.

When a user follows the beg screen - they are taken to a subscription page. When Paypal is the primary payment option - the user is presented with a "pay with paypal" image. If the user clicks on the paypal image to pay they are returned back to the exact same page.

I've tried switching themes - each theme returns the same error code below:

[Fri Sep 06 14:01:42 2013] [error] [client 67.191.122.159] File does not exist: /home/XXXXXX/public_html/wp-content/themes/network/favicon.ico

[Fri Sep 06 12:35:08 2013] [error] [client 109.169.76.104] PHP Fatal error: Call to undefined function add_action() in /home/XXXXXX/public_html/wp-includes/canonical.php on line 506

[Fri Sep 06 12:35:07 2013] [error] [client 109.169.76.104] PHP Fatal error: Call to undefined function add_action() in /home/XXXXXX/public_html/wp-includes/author-template.php on line 392

[Fri Sep 06 12:35:06 2013] [error] [client 109.169.76.104] PHP Fatal error: Call to undefined function add_action() in /home/XXXXXX/public_html/wp-includes/admin-bar.php on line 39

[Fri Sep 06 12:35:04 2013] [error] [client 109.169.76.104] File does not exist: /home/XXXXXX/public_html/wp-includes/js/thickbox/"+imgLoader.src+"

[Fri Sep 06 12:35:04 2013] [error] [client 109.169.76.104] File does not exist: /home/XXXXXX/public_html/wp-includes/js/jquery/,e):this:v.isFunction(e)

[Fri Sep 06 12:35:03 2013] [error] [client 109.169.76.104] File does not exist: /home/XXXXXX/public_html/wp-includes/js/jquery/,data:n,complete:function(e,t){r&&u.each(r,o||[e.responseText,t,e])}}).done(function(e){o=arguments,u.html(i

[Fri Sep 06 12:35:02 2013] [error] [client 109.169.76.104] File does not exist: /home/XXXXXX/public_html/wp-includes/js/jquery/));Nt.optgroup=Nt.option,Nt.tbody=Nt.tfoot=Nt.colgroup=Nt.caption=Nt.thead,Nt.th=Nt.td,v.support.htmlSerialize||(Nt._default=[1,

[Fri Sep 06 12:35:02 2013] [error] [client 109.169.76.104] File does not exist: /home/XXXXXX/public_html/wp-includes/js/jquery/&&!yt.test(e)&&(v.support.htmlSerialize||!wt.test(e))&&(v.support.leadingWhitespace||!pt.test(e))&&!Nt[(vt.exec(e)||[

Again - the plugin is functioning properly using Stripe - these codes are only for the Paypal Express Checkout option.

As I post this - I realized that I'm probably being a big baby about not wanting to pay $140 a year for an SSL certificate but my plan right now is to plant several of these multi-site "seeds" and see which ones sprout.

  • divva

    Jack -

    I originally posted this on a similar report here which had been marked as resolved. I mistakenly "reopened" it and was instructed to open a new thread. The reason I began using Stripe is that was the action taken by the author of the original report from over a year ago.

    I decided to include the error log entries to see if that would shine a bright light on the issue. Honestly, when I saw it was calling for a favicon icon - I was hoping that would make sense to someone there because I thought that was VERY strange. (Tried uploading a favicon to the folder to see if that was the "magic"key - it wasn't.)

    FYI: my VPS a unix box is running PHP Version 5.3.22 - if anyone else is having this issue.

    I just tried it with only the WPMU dashboard plugin and Pro-sites active (both are most recent versions)- but it's still not working.

    I'm going to mark this as resolved - because it is thanks to Stripe. My CPA has been haranguing me for a decade over the excessive Paypal fees I pay - so I'll quit being stubborn and embrace the new kid on the block. <grin>

    Thanks for all your help.

  • Jack Kitterhing

    Hi there @divva

    I hope you are well today and thanks for the additional information.

    Stripe is quite honestly fantastic and I'm sure your like it :slight_smile:

    The favicon .ico, is asking for a .ico image, but that wouldn't fix this unfortunately, I'd be happy to help you get to this bottom of this with the PayPal issue if you'd like, feel free to open this if you'd me too :slight_smile:

    Thanks for being a WPMU DEV member and have a great day!

    Kind Regards
    Jack.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.