Product theme.

I looked in the header.php file and default values are given for site title and site description if they are not provided by me. However, when I change the site title and description in the admin panel nothing happens on the front end and the default values are still displayed. What is going on?

EDIT: I just noticed I cannot add text for slides, only image slide options are available. Even when I add an image slide nothing is displayed. It seems like many of the options in the control panel have no effect

  • Tammie

    @zazinteractive: Hmm sounds to me like something is clashing with product like a plugin or something is up with the install. We are not aware of any current issues in the theme and certainly haven't without another issue seen that type of behaviour as a bug.

    Lets get on the same page for testing purposes though.

    1. Please download the latest version
    2. Make sure you've followed our installation instructions
    3. Turn off all other plugins - you can leave BuddyPress
    4. Make sure you are up to date with WordPress and BuddyPresss (3.1 / 1.2.8)
    5. Clear your browser cache
    6. Try again

    If you still have issues please update this thread with a link to your site so I can see for myself the front end.

  • Tammie

    Looks like somehow jquery isn't loading for you then as the difference in versions was when we moved to enqueue not declaring a file. Can you try the attached file please instead of library/functions/option-functions.php (just replace it). If that doesn't work we may have to directly declare jquery but we shouldn't assuming your installation has been correctly. My other thoughts are somehow that's not happened or the browser cache is kicking in. Lets see though with this file.

    Please make sure you clear your cache.

  • Tammie

    Ok first up went into your site zazinteractive today and tried uploading 2.2.5. It worked however I notice you have cache installed so.. it's possibly that. As you had not provided me a full admin account I couldn't disable this or see if network active (in future please give an account I have access to network plugins in as makes things easier to diagnose). If this was network active then this would / could explain why those files I sent did not work.

    I can't recreate this in my testings so it's something whilst not unique but still not the same as a vanilla install on your sites. That is not saying we won't get a solution.

    So.. I have a few suggestions which also apply to you @danieldalonzo (please don't use version 1.5)

    1. Turn off any cache plugins and try the files attached to this thread
    2. Turn off any cache plugins and try the file attached to this thread and the other files with it. (it goes under library/scripts)
    3. Make sure when you test you clear your browser cache - these 3 steps are very very important as I will be assuming done and if it turns out none were done it's a total waste of time and a solution may be a very long time coming as a result of the wrong information.
    4. If none of these works please give me admin access to plugins and I can review again. I also need to know what browser you were in. This could be having an impact also - I suggest we all try using firefox as a level playing field. We can then move into seeing if browser related.

  • Tammie

    Attached are 2 proofs, however it would be prudent in moving forward to understand we never state things we do not test. We always aim to get it working as best we can on a clients site and never claim 'it works' without trying.

    A few points:

    1. No title does not work on your site BUT as you have cache and also an SEO plugin installed on your network this interacts with that. The title I am referring to is under your Simple SEO settings. You don't use 2 SEO solutions so therefore simple SEO is just that it's to use if you don't use anything else. I also can't be sure that cache isn't playing a part. I re uploaded several times header.php today yet each time see no change.

    However, it works for description and on my own test site it works for every single site. Therefore my suggestion is you use the solution you are using for your site. We would never recommend simple SEO over a full SEO solution. It is just that 'a simple solution' and bare bones in that sense.

    2. Cache doesn't help me nor does not having full admin rights. Imagine being a plumber and asked to fix a leaky pipe which needs replacing. The pipe is in a room but the turn off valve for water is in another locked room which you won't give me the key to. Not going to result in your leaky pipe being fixed that well or at least not without lots and lots of water and buckets and so on :slight_smile:

    3. As shown in the second image I can use tabs - tabs are effected by jquery (not sure why you claim they aren't). However, for me they work. I cleared my browser cache, I also tested on my site several times and each time it works well.

    4. I can assume you 2.2.5 works it's not in your case of Daniels for the reasons I think already outlined. I'm happy to work with both of you to get a solution and if we find other issues we always fix them asap. We do not leave our users without working solutions. We even log into your servers to try and help should we not get anywhere in forums. Not that many sites would do that for you.

  • zazinteractive

    I see the slides tab but how do I add text to my slides? There's only options for images. Also the tabs do not load on the main page http://zazinteractive.com. I guess you didn't understand my first post.

    I'm using a typical server with no plugins so If it doesn't work on that then it won't work on a lot of sites. The theme shouldn't need a fix, I should be able to activate and just use it right away. You know there's something wrong when 5 releases of the same version have been released in the span of 1 week,

    Anyways I gave you super-admin rights...

  • Tammie

    Thank you admin rights meant it was much easier to sort out for you.

    First up I've applied a fix which it did need because of your network plugin combination - it happens sometimes but it's done now we always fix any issues. There was nothing wrong in most installs as I thought it was that we had a situation I need admin and to work on your server. Now anyone else with this issue can benefit which I thank you for helping achieve.

    I have released a new full version of the theme. Whilst not all will experience it this warrents a full release and a change log to make sure those that may be update.

    This week if you are unaware 3.1 and 1.2.8 dropped which has meant releases and fixing. Coupled with this we have done extensive WPDEBUG work and also working with our plugin betas such as membership. This was not a usual week in the form of activity.

    I encourage you to test and be sure but I tested all your issues and could do them. What basically was happening was it wasn't loading the right options as a result the tabs and then content. This of course was a bad thing resulting in the theme not loading everything it was meant to and you seeing a partial warped picture with the wrong names. Of course bad. I have made sure it now shows everything correctly.

    You will probably have to add in your content-blocks no show content again as I have locked it down to where possible use the theme options. I want to avoid repeat issues.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.