Problem with SSL on Multisite

Hello
I am having troubles with SSL certification on my WordPress Multisite setup.
The problems with the SSL certificates started out of the blue this autumn. My sites were deemed "not secure" by all browsers.
And when I contacted the hosting company they added certificates and turned on "Lets Encrypt" and everything worked fine.

But then all their computers crashed, and after rebuilding their clients sites my sites were all insecure again.

I managed to get it working on the root web by adding and configuring the two plugins:
https://wordpress.org/plugins/really-simple-ssl/
and
https://wordpress.org/plugins/ssl-insecure-content-fixer/

this worked for the main site and now some of the subsites are OK too, but not all of them

My hosting company has come to the end of their knowledge on WPMU and told me that all their clients have abandond multisite!!!

Can YOU help me here?

Thank you very much

  • Nahid
    • Tech Support

    Hey hrobjartur !
    Hope you are having a great day!

    This is indeed a weird issue but we cannot really provide much insight without looking into and troubleshooting it. If the site is showing as 'Insecure' in browsers, some of my primary thoughts are:
    > Either the SSL certificate is encountering issues, i.e. not working properly.
    > Or the Multisite wasn't set up properly to use https, resulting in mixed content errors.

    Could you enable Support Access on the Multisite installation so that we can take a closer look into it? This handy guide should help you do that.

    Please also mention the subsites in which you are encountering the issue at the moment. If the URLs are sensitive information and you would not like to share them in this public forum, please mention the Blog IDs or mask out certain characters in the URLs with asterisks(*).

    We'll be looking forward to hearing back from you. Thanks!

    Kind regards,
    Nahid

  • hrobjartur
    • Design Lord, Child of Thor

    Thanks Nahid
    I have opened for support access.
    I have 9 subsites on this multisite and for some reason I get a privacy error for these five:
    skipulagning-2018.namfullordinna.is (This is the most important one now)
    skipulagning-2017.namfullordinna.is
    skipulagning-2016.namfullordinna.is
    skipulagning.namfullordinna.is
    saerunrosa.namfullordinna.is
    My hosting company has activated certificates from "Lets Encrypt" and when I run a test I get the message that there is a discrepancy in the domain names:
    "Alternative names *.1984.is 1984.is MISMATCH"

    Thanks a lot
    Hróbjartur

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.