Problem with the membership login-widget.

I have a problem with the membership login-widget.

Sometimes when logging in I get redirected to a white screen with the text "blocked".

I also have a problem with users changing back to their origin level.

They register for free and they are set to visitor-level, I then move them manually to another level. After about a day the users complain that they can't log in to their group, and when looking in the admin I find that they are reset to visitor-level again.

  • Michael Bissett

    Hi @Anna, welcome to the WPMU DEV Community, hope you're doing well today! :slight_smile:

    In regards to this:

    I have a problem with the membership login-widget.

    Sometimes when logging in I get redirected to a white screen with the text "blocked".

    Does this only take place with admin users on your site, or anyone that tries to log in? Would you have a security plugin or a firewall in place on your site?

    I'm not able to replicate this on my site presently, do you notice a particular pattern to this behavior?

    I also have a problem with users changing back to their origin level.

    They register for free and they are set to visitor-level, I then move them manually to another level. After about a day the users complain that they can't log in to their group, and when looking in the admin I find that they are reset to visitor-level again.

    I'd like to have a closer look at your settings for this one, could you enable Support Access on your site please?

    Thanks a bunch! :slight_smile:

    Kind Regards,
    Michael

  • Anna

    This is a strange issue! Did it happen for only one user or all users? Is there any pattern that after how long time the subscription got reset?

    It happened with various users, I can't tell you if it was all users.
    I do not know if it is a pattern, other than that the users settings randomly changed back to their origin level

    Also, I have just repaired your membership tables. Please check and let us know if it happens again.

    Thank you!

    About the login widget, does it happen with your default theme? Again, is there any pattern?

    I have not used the default theme, but have installed a theme called Nirvana.

    Kind Regards,
    Anna

  • Anna

    Hi Ash

    Is it possible for you to check login widget with default theme and deactivating all other plugins? I am saying this because, there is no text "blocked" in membership login widget, so it's coming from some other resource.

    You are right, it might be the theme.

    But this is a minimal problem right now, as the problem with users still reverting back to the initial assigned level persists.

    This morning multiple users where again reverted back to visitor status, from the assigned level.

    The more users I get assigned, the more frustrating this constant re-assigning users to correct level after they have reverted back to visitor level for no obvious reason becomes.

    Is there any log, function-log, bug-log or hidden features I'm not aware of?

    Have I configured the site wrongly?

    Kind Regards,
    Anna

  • Ash

    Hello @Anna

    I think I found the issue. I should have checked earlier.

    All of your users are in "Registered" subscription plan and there the period is set to 1 day only. So, after 24 hours, the member is dropped.

    Would you please try increasing the period here?

    Also, I can see you have assigned some levels to an user that are not associated with any subscription. Would you please add those levels in a subscription plan and then assign the subscription to that user? You can make the plan private so that normal users wont have access to that plan.

    Hope it helps :slight_smile: Please feel free to ask more question if you have.

    Cheers
    Ash

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.