problem with Toggle button to protect page

I have 3 memberships and I'd like all pages that have "video" in their title to be accessible only for 2 memberships. Just like this : http://i.imgur.com/heQ0ng9.png
BUT when I save, the toggle button comes back to grey and most of the time the page is not protected. Here's a video too : https://www.youtube.com/watch?v=IOQ9ZuhKEks
(I have granted Support access)
Thanks a lot for your help!
Thomas

    Adam Czajczyk

    Hey Thomas,

    I hope you're well today and thank you for your question!

    I've accessed your dashboard and played a bit with your posts. I've made changes in content protection settings for the post that's presented on the screenshot you've attached here. Apart from the "Enable protection" button turning gray, the protection seems to work fine. I guess this behavior of "Enable protection" button might be caused by the page builder's extensions you seem to be using.

    Otherwise however, the protection works fine for me. I was able to protect the post for every membership as well as open it (checked both in Chrome's incognito mode and standard Firefox mode being logged out of my WPMU profile). That said, I suspect that it might be a browser-related issue. Have you tried another browser and/or are you using any additional caching/acceleration extensions with your browser?

    Please advise!

    Cheers,
    Adam