Problem with ultimate Facebook and Buddypress Groups

Hello - I am having problems syncing Buddypress Groups with Ultimate Facebook plugin. The error message is as follows: Invalid Scopes: user_groups. This message is only shown to developers. Users of your app will ignore these permissions if present. Please read the documentation for valid permissions at: https://developers.facebook.com/docs/facebook-login/permissions

  • Jaymz Yates

    Hello..

    The steps I take are to navigate to the buddypress groups page, click on a group, click on manage and then click sync group with facebook. I then get that error.

    However, I don't think you can test it on my site as I now have a memory issue when Ultimate Dacebook plugin is enabled. The error is [14-Apr-2016 00:18:33 UTC] PHP Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at /home/ntfg/northtexasfishinggroup.com/wp-config.php:99) in /home/ntfg/northtexasfishinggroup.com/wp-content/plugins/wpmu-dev-facebook/lib/external/facebook.php on line 60

    Sorry - Not sure what to do about that so I had to disable the plugin.

    Support is enabled on the site.

  • Michael Bissett

    Hey Jaymz Yates, Michael here, apologies for the delay on this one!

    Got a couple of questions here for you:
    - What the lowest API version that your app's able to use? You'd be looking for that in your app's Dashboard:

    I ask because that permission's only usable if the app can access version 2.3 (or lower) of Facebook's API.

    - On that error you mentioned:

    [14-Apr-2016 00:18:33 UTC] PHP Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at /home/ntfg/northtexasfishinggroup.com/wp-config.php:99) in /home/ntfg/northtexasfishinggroup.com/wp-content/plugins/wpmu-dev-facebook/lib/external/facebook.php on line 60

    What's at the end of your site's wp-config.php? It should look like this:

    /* That's all, stop editing! Happy blogging. */
    
    /** Absolute path to the WordPress directory. */
    if ( !defined('ABSPATH') )
    	define('ABSPATH', dirname(__FILE__) . '/');
    
    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');

    With no closing ?> at the end, and nothing else below that "That's all" line, aside from what you see in the example.

    Please advise,
    Michael

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.